IBM Support

ANS1977E CadSchedName registry value is empty

Troubleshooting


Problem

The Tivoli Storage Manager Client Acceptor fails to start.

Symptom

ANS1977E Dsmcad schedule invocation was unsuccessful. This command will be tried again in 10 minutes. Error starting schedule service: CadSchedName registry value is empty

Cause

The value for the cadSchedName is blank in the registry.

Environment

Windows

Resolving The Problem

To fix the error, uninstall/remove the dsmcad service and reinstall it; be sure to specify the name of the scheduler service that will be managed by the dsmcad:

1. Using a windows command prompt navigate to the baclient directory.

2. To remove the dsmcad service issue:
dsmcutil remove /name:”<yourCadName>”

3. To reinstall the dsmcad service issue:
dsmcutil install cad /name:<yourCadName> /node:<node> /password:<pswd> /autostart:yes /startnow:yes /optfile:”<path_to_opt_file” /cadschedname:”<SchedName>”
For example:
dsmcutil install cad /name:"TSM Client Acceptor" /node:TRISHACLUSTER /password:******* /autostart:yes /startnow:yes /optfile:”e:\dsm.opt” /cadschedname:”TSM Schedule Keywest

4. From the following registry key the value of CadSchedName should no longer be blank:
HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Services/<yourClientAcceptor>/Parameters
(Replace <yourClientAcceptor> for the name of your client acceptor)

[{"Product":{"code":"SSGSG7","label":"Tivoli Storage Manager"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Client","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Product Synonym

TSM

Document Information

Modified date:
17 June 2018

UID

swg21296700