Installing Lotus Domino and related products on IBM i 6.1 or 7.1

Technote (FAQ)


Question

What must be done differently when installing Lotus® Domino® or a related product on IBM i 6.1 or 7.1?

Answer

This technote pertains only to new installs of Lotus products on a system running IBM i 6.1 or 7.1. If you are upgrading a current installation from V5 to i 6.1 or 7.1, see Upgrade roadmap for Lotus Domino and related products on i 6.1 and later releases (technote #1294587 ).

For additional information about IBM i 6.1 and later releases, see Lotus Domino for i5/OS V6R1 Planning.


When installing one of the products listed below, your main source of information is the installation guide for that product. See Lotus documentation. This technote only provides information about special considerations when installing on IBM i 6.1 or i 7.1.

Note: The information in this document may not necessarily reflect all Lotus product releases that have shipped since IBM i 6.1 availability in March, 2008 and i 7.1 availability in April 2010. To determine the IBM i operating system compatibility characteristics of releases that are not listed here, see the Lotus Software for IBM i Compatibility Guide.

This document contains the following sections:

  • Summary of installation considerations
  • Program conversion recommendations
  • Controlling program conversion during installation
  • Running program conversion manually after installation
  • Program Conversion on i5/OS V5



Summary of installation considerations

Releases supported on i 7.1
Compatible Domino Release
Special Considerations and Additional Information
Lotus Domino 8.5.1 and later N/A -- Program conversion is not required when installing Domino 8.5.x on IBM i 7.1. However, program conversion is mandatory and cannot be deferred when:
    -- installing Domino 8.5.x on i 5.4 (V5R4), or
    -- upgrading a Domino 8.5.x installation from i 5.4 to i 7.1
For more information, see Domino 8.5 for i: Program Conversion (technote #7013152).
Lotus Enterprise Integrator 8.5.2 Domino 8.5.2 -- Program conversion is not required when installing LEI 8.5.x on IBM i 7.1. However, program conversion is mandatory when:
    -- installing LEI 8.5.x on i 5.4 (V5R4), or
    -- upgrading an LEI 8.5.x installation from i 5.4 to i 7.1
-- Since LEI requires the corresponding release of Domino, the Domino program conversion implications also apply. Program conversion of Domino requires significantly more time than LEI.

See Prerequisites for installing Lotus Enterprise Integrator on IBM i 7.1, 6.1 or 5.4 (technote #1299738).

Lotus Quickr® 8.5 and 8.5.1 for Domino Domino 8.5.1 FP3 or later FP -- No enabling fix is required for Lotus Quickr 8.5 or 8.5.1 to run on Domino 8.5.1.
Lotus Sametime® 8.5.1 and 8.5.2 Domino 8.5.1 or 8.5.2
Lotus Workflow® 7.0 Domino 8.5.1 or 8.5.2
IBM Integrated Domino Fax V4R5 Domino 8.5.1 or 8.5.2 -- Install the latest available fixes for Integrated Domino Fax V4R5.

Releases supported on i 6.1
Compatible Domino Release
Special Considerations and Additional Information
Lotus Domino 8.5.x N/A -- Program conversion is not required when installing Domino 8.5.x on IBM i 6.1 (V6R1). However, program conversion is mandatory and cannot be deferred when:
    -- installing Domino 8.5.x on i 5.4 (V5R4), or
    -- upgrading a Domino 8.5.x installation from i 5.4 to i 6.1
For more information, see Domino 8.5 for i: Program Conversion (technote #7013152).
Lotus Domino 8.0.1 or 8.0.2 N/A -- Consider deferring program conversion until after product install. Do not run Domino commands until conversion is complete. See "Running program conversion manually after installation," later in this document.
Lotus Domino 7.0.3 or 7.0.4 N/A -- Support for Domino 7.0.x ended on April 30, 2011. However, Domino 7.0.x can still be used to run Domino Document Manager until its support period ends on Sept 30, 2012.

-- Highly recommended that you defer program conversion during installation. Do not run Domino commands until conversion is complete. See "Running program conversion manually after installation," later in this document.

-- Domino 7.0.3 requires a hot fix or fix pack to run on V6R1. See Enabling Lotus Domino 7.0.3 for i5/OS V6R1

Lotus Domino Document Manager 7.0 Domino 7.0.4 or

7.0.3 with required fix

-- Though support for Domino 7.0.x ended in April 2011, Domino 7.0.x can still be used to run Domino Document Manager until its support period ends on Sept 30, 2012.

-- DDM 7.0 requires an enabling fix to run on V6R1.

Lotus Enterprise Integrator 8.5.x Domino 8.5.x -- Program conversion is not required when installing LEI 8.5.x on IBM i 6.1 (V6R1). However, program conversion is mandatory when:
    -- installing LEI 8.5.x on i 5.4 (V5R4), or
    -- upgrading an LEI 8.5.x installation from i 5.4 to i 6.1
See Prerequisites for installing Lotus Enterprise Integrator on IBM i 7.1, 6.1 or 5.4 (technote #1299738).
Lotus Enterprise Integrator 8.0.2 Domino 8.0.2 -- See Prerequisites for installing Lotus Enterprise Integrator on IBM i 7.1, 6.1 or 5.4 (technote #1299738).

-- Support for LEI 7.0.x ended on April 30, 2011.

Lotus Enterprise Integrator 8.0.1 Domino 8.0.1
Lotus Quickr® 8.5 and 8.5.1 for Domino Domino 8.5.1 FP3 or later FP -- No enabling fix is required for Lotus Quickr 8.5 or 8.5.1 to run on Domino 8.5.1.
Lotus Quickr® 8.2 Domino 8.5 or 8.5.1 -- Lotus Quickr 8.2 requires an enabling fix to run on Domino 8.5.1. See About "Lotus Quickr 8.2 Enabling Fix for Domino 8.5.x" (technote #1405489 ).
Lotus Quickr 8.1 Domino 8.0.1 or 8.0.2 -- Lotus Quickr 8.1 requires an enabling fix to run on Domino 8.0.2. See About "Lotus Quickr 8.1 i5/OS Enabling Fix for Domino 8.0.x" (technote #1316470 ).

-- Support for Lotus Quickr 8.0 and 8.0.0.2 ended on April 30, 2011.

Lotus Sametime® 8.5.1 and 8.5.2 Domino 8.5.2, 8.5.1, 8.5.0 or 8.0.x
Lotus Sametime® 8.5 Domino 8.5.1, 8.5.0 or 8.0.x
Lotus Sametime 8.0, 8.0.1 or 8.0.2 Domino 8.0.1 or 8.0.2 -- Support for Domino 7.0.x ended on April 30, 2011.

-- Sametime 7.5.1 support will end on September 30, 2011. Not recommended for new installations.

Lotus Sametime
Gateway 8.5.x or 8.0.x
N/A -- For special considerations when installing on IBM i 6.1, see About Lotus Sametime Gateway and i5/OS V6R1 (technote #1295898).
Lotus Workflow® 7.0 Domino 8.5.x, or 8.0.x
IBM Integrated Domino Fax V4R5 Domino 8.5.x or 8.0.x -- Domino Fax was withdrawn from marketing in January, 2011, and support ends on April 30, 2012.

-- Install the latest available fixes for Integrated Domino Fax V4R5.

-- Support for Domino 7.0.x ended on April 30, 2011.



Program conversion recommendations

If program conversion occurs during the installation of Domino on i 6.1 or i 7.1, the process may take significantly longer to complete than in previous releases due to the size of the service programs in the product. Conversion is a long-running process that may take from 10 to 90 minutes or longer. The actual time needed to complete the conversion depends on the performance characteristics of the system, including: speed of the processor, number of processors, priority of the job, disk arms attached, memory available, and other system activity.

In certain cases, it is better to avoid running program conversion during product installation and then run it manually afterwards. For example, Domino Document Manager and Domino 7.0.3 each require a fix to run on i 6.1. If you run conversion for Domino Document Manager before installing the fix, the install will fail. If you run conversion while installing Domino 7.0.3, you will need to run conversion again after installing the fix. See table above for links to more information for these products.

Of course, you may decide to defer conversion when installing any of the Lotus products. In this case it is highly recommended that you run program conversion manually before using the product.

Hint: If you are planning to install a Domino release prior to 8.5 on several i 6.1 systems, you can reduce the conversion impact by installing the product on one system, applying fixes if necessary, completing program conversion, and then saving the Domino product. When you use the saved Domino product for installation on your other i 6.1 systems, program conversion is not necessary.

Note! If you deferred program conversion when installing a Domino release prior to 8.5, do not use any of the Domino commands until after you have run program conversion manually. When the programs have not yet been converted, conversion is started when you run one of the commands (STRDOMSVR, CFGDOMSVR, CHGDOMSVR, UPDDOMSVR). Because Domino conversion is a long-running process, this can appear to be a hang condition or may prevent the server from starting successfully due to time-outs. The result depends on the performance characteristics of your system.

More detailed information is provided in the following two sections of this document:
Controlling program conversion during installation
Running program conversion manually after installation


Controlling program conversion during installation

Whether or not program conversion occurs during product installation is typically controlled by:

1. The QFRCCVNRST (Force conversion on restore) system value. To view or change the system value, run the following command:

WRKSYSVAL QFRCCVNRST

2. The FRCOBJCVN keyword value on the RSTLICPGM command.

Domino provides an additional method for deferring program conversion when using one of the interactive install methods (setup.exe or LODRUN). You can defer program conversion by creating a data area called QNNICVNRST in library QUSRSYS. If the data area exists, objects are not converted when installing Domino using setup.exe or LODRUN. Note that the data area is not used for installs using RSTLICPGM or for any products other than Domino.

To create the data area QNNICVNRST in library QUSRSYS, run the following command:

CRTDTAARA DTAARA(QUSRSYS/QNNICVNRST) TYPE(*CHAR) LEN(10 1) VALUE(V6R1)

The following table summarizes the settings you can use to control whether or not program conversion occurs during product installation:

Convert
during Install?
Install Method
QFRCCVNRST
System Value
Domino *DTAARA (*)
Install from save file using RSTLICPGM commands
Convert RSTLICPGM with
FRCOBJCVN(*SYSVAL)
2 or greater
All objects will be converted
n/a
Convert RSTLICPGM with
FRCOBJCVN(*YES *RQD)
Any
All objects will be converted if required.
n/a
Defer conversion RSTLICPGM with
FRCOBJCVN(*SYSVAL)
0 = Do not convert anything
n/a
Defer conversion RSTLICPGM with
FRCOBJCVN(*NO)
FRCOBJCVN(*NO) is only allowed when QFRCCVNRST is set to "0" or "1"
n/a
Install from physical media using LODRUN command
Convert LODRUN using physical media For Domino: 2 or greater
All objects will be converted
QUSRSYS/QNNICVNRST does not exist
For non-Domino: 2 or greater
All objects will be converted
n/a
Defer conversion LODRUN using physical media For Domino:
Any setting
QUSRSYS/QNNICVNRST exists
For non-Domino:
0 = Do not convert anything
n/a
Install from Web kit or physical media using SETUP.EXE (Domino only)
Convert SETUP.EXE using Web kit or CD 2 or greater
All objects will be converted
QUSRSYS/QNNICVNRST does not exist
Defer conversion SETUP.EXE using Web kit or CD Any QUSRSYS/QNNICVNRST exists
* To create the *DTAARA QNNICVNRST in library QUSRSYS to defer program conversion during Domino install using LODRUN or SETUP.EXE, run the following command:
CRTDTAARA DTAARA(QUSRSYS/QNNICVNRST) TYPE(*CHAR) LEN(10 1) VALUE(V6R1)


Running program conversion manually after installation

If you deferred program conversion during product installation, use the commands in the table below to run it manually.

Note: The STROBJCVN command can be run interactively from a command line or submitted to batch using the SBMJOB command. Batch mode is highly recommended for the Domino libraries because the conversion process can run for a long time, but batch mode can be used for any of the products.

  • To run program conversion in batch mode:

    SBMJOB CMD(STROBJCVN OPTION(*CONVERT) LIB(<library_name>) )

  • As instructed previously, do not run any Domino commands until Domino product conversion is complete. To determine whether conversion is complete for Domino, check whether the LIBNOTES service program has been converted by running the following command:

    DSPSRVPGM SRVPGM(<Domino_program_library>/LIBNOTES)


Page down to the "Service program statistics" information and locate the "Conversion required" entry. A value of *NO indicates that conversion is either not required or the service program is already converted. A value of *YES indicates that conversion is required or has not yet completed. Only run Domino commands if the conversion required value is "*NO".

Product
Command to convert programs
Lotus Domino 8.5.x Not applicable.

Program conversion is not required when installing Domino 8.5.x on i 6.1 or i 7.1. For more information, see Domino 8.5 for i: Program Conversion (technote #7013152).

Lotus Domino 8.0.1 or 8.0.2 Batch mode is recommended:

SBMJOB CMD(STROBJCVN OPTION(*CONVERT)
LIB(QDOMINO801))

or

SBMJOB CMD(STROBJCVN OPTION(*CONVERT)
LIB(QDOMINO802))

Note: Additional Domino product libraries QNOTES and QNOTESAPI are relatively small and can be converted on first-touch without any noticable impact. STROBJCVN may be used, but is not required.

Lotus Domino 7.0.3 or 7.0.4 Note: Though support for Domino 7.0.x ended in April 2011, Domino 7.0.x can still be used to run Domino Document Manager until its support period ends on Sept 30, 2012.

Batch mode is recommended:

SBMJOB CMD(STROBJCVN OPTION(*CONVERT)
LIB(QDOMINO703))

or

SBMJOB CMD(STROBJCVN OPTION(*CONVERT)
LIB(QDOMINO704))

Note: Additional Domino product libraries QNOTES and QNOTESAPI are relatively small and can be converted on first-touch without any noticable impact. STROBJCVN may be used, but is not required.

Lotus Domino Document Manager 7.0 STROBJCVN OPTION(*CONVERT) LIB(QDOMDOC)
LEI 8.5.x Not Applicable.

Program conversion is not required when installing LEI 8.5.x on i 6.1 or later.

LEI 8.0.1 or 8.0.2 Batch mode is recommended:

SBMJOB CMD(STROBJCVN OPTION(*CONVERT)
LIB(QDOMINO801))

or

SBMJOB CMD(STROBJCVN OPTION(*CONVERT)
LIB(QDOMINO802))

Lotus Quickr for Domino
(all supported releases)
Conversion is not required when installing Quickr 8.5 or later on i 6.1 or i 7.1. For earlier Quickr releases:

STROBJCVN OPTION(*CONVERT) LIB(QQPLACE)

Lotus Sametime Domino-based servers

(all supported releases)
Conversion is not required when installing Sametime 8.5.1 or later on i 6.1 or i 7.1. For earlier Sametime releases:

STROBJCVN OPTION(*CONVERT) LIB(QSAMETIME)

Lotus Sametime WAS-based servers
(all supported releases)
Not applicable.

The WebSphere-based Sametime servers (Gateway, Meeting Server, Proxy Server and System Console Server) do not contain any programs that require conversion.

Lotus Workflow 7.0 Not applicable.

Lotus Workflow does not contain programs that require conversion.

IBM Integrated Domino Fax V4R5 STROBJCVN OPTION(*CONVERT) LIB(QDOMFXD)


Program Conversion on IBM i 5.4

Many of the product releases described in this technote require program conversion on i 6.1 or i 7.1. (The exceptions are: Domino 8.5x, LEI 8.5x, Quickr 8.5x and Sametime 8.5.1 or later.) Some of the products also require fixes. For Domino releases prior to 8.5, special considerations are necessary due to the length of time required to convert the product library.

Keep in mind that once program objects have been installed and converted on i 6.1 or i 7.1, moving the objects back to an i 5.4 system will make it necessary to run conversion again. For example, if you install Domino 8.0.x on i 6.1, convert the product library, save the Domino product and then restore the converted product on a 5.4 system, program conversion is required before you can run the product. It is preferable to use the original product media when installing on a 5.4 system in order to avoid the long conversion time.

When installing on i 5.4, the QNNICVNRST data area cannot be used to defer conversion during restore. To defer conversion during restore, use the QFRCCVNRST system value and/or the RSTLICPGM command's FRCOBJCVN keyword as described earlier in "Controlling program conversion during installation."

Related information

i5/OS V6R1 planning for Domino and related products
i5/OS V6R1 upgrade roadmap for Lotus Domino and related

Cross reference information
Segment Product Component Platform Version Edition
Organizational Productivity- Portals & Collaboration Lotus Quickr for Domino Configuration i5/OS, IBM i 8.5.1, 8.5, 8.1, 8.0.0.2, 8.0
Messaging Applications Lotus End of Support Products Lotus Domino Document Manager i5/OS 7.0
Messaging Applications Lotus Workflow Not Applicable i5/OS 7.0
Organizational Productivity- Portals & Collaboration IBM Sametime Install/Configuration i5/OS, IBM i 8.5.1, 8.5, 8.0.2, 8.0.1, 8.0, 7.5.1, 8.5.2
Business Integration IBM Enterprise Integrator for Domino Install/Configuration i5/OS, IBM i 8.5.2, 8.5.1, 8.5, 8.0.2, 8.0.1, 7.0.4, 7.0.3

Rate this page:

(0 users)Average rating

Document information


More support for:

IBM Domino
Deployment

Software version:

7.0.3, 7.0.4, 8.0.1, 8.0.2, 8.5, 8.5.1, 8.5.2, 8.5.3

Operating system(s):

IBM i, i5/OS

Reference #:

1295455

Modified date:

2011-06-05

Translate my page

Machine Translation

Content navigation