Technote (troubleshooting)
Problem(Abstract)
Post migration to IBM WebSphere Application Server Network Deployment fails with "com.ibm.wsspi.migration.document.exceptions.NotFoundException" error instead of a file permissions error.
Symptom
The trace log reports:
...com.ibm.wsspi.migration.document.exceptions.NotFoundException...
...
...MIGR0286E: The migration failed to complete
Above this exception, the migration tool may report that it is unable to find a file in the
"optionalLibraries" subdirectory in the product, yet the file is actually present.
Cause
The files in the <product_install_location>/optionalLibraries directory may not have read/write permission assigned to them. The system reports "Not Found Error" instead of a file permissions error.
Diagnosing the problem
If the trace log reports "com.ibm.wsspi.migration.document.exceptions.NotFoundException", check the file permissions in the "optionalLibraries" subdirectory.
Resolving the problem
Ensure that the file permissions in the "<product_install_location>/optionalLibraries" folder allow appropriate read/write access for the user. Setting the permissions to "755" should help resolve the issue.
Related information
Rate this page:
Copyright and trademark information
IBM, the IBM logo and ibm.com are trademarks of International Business Machines Corp., registered in many jurisdictions worldwide. Other product and service names might be trademarks of IBM or other companies. A current list of IBM trademarks is available on the Web at "Copyright and trademark information" at www.ibm.com/legal/copytrade.shtml.