Troubleshooting
Problem
This technote explains why the IBM® Rational® ClearCase® view server process stops working after 30 minutes and reports license errors like []Error: Lic err from FLEXlm: Cannot connect to license server[] after the FLEXlm license has expired.
Symptom
The messages logged into the view_log file are as follows:
2007-11-06T12:00:55+01 view_server(16216): Error: Lic err from FLEXlm: Cannot connect to license server
2007-11-06T12:00:55+01 view_server(16216): Error: There are no valid licenses in /var/adm/rational/clearcase/license.db for ClearCase
Cause
This issue could be caused by either of the following:
- This error appears when the port that is used for licensing has been changed.
Note: The default port for FLEXlm licensing is 27000.
- This error and scenario where cannot get a license could also be due to improper syntax in the Flexlm_host file.
Resolving The Problem
Solution 1
Change the port that is used for FLEXlm licensing to 27000.
Locate and edit the flexlm_host file on the ClearCase server to ensure port 27000 is used.
Note: By default the flexlm_host file is located in one of the following directories:
/var/adm/rational/clearcase/config
/opt/rational/clearcase/config/rcl/
If you have flexlm_host file in both directories, remove the one located in the below directory as it is not required:
/opt/rational/clearcase/config/rcl
Solution 2
Correct the syntax in the flexlm_host file
Incorrect syntax is:
- SERVER 27000@license-server ANY
USE_SERVER
Correct syntax is:
- SERVER <hostname> ANY 27000
USE_SERVER
Related Information
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Document Information
Modified date:
16 June 2018
UID
swg21287504