IBM Support

RFT fails to enable Internet Explorer browser for testing

Troubleshooting


Problem

Microsoft Internet Explorer browser enablement fails for testing with IBM Rational Functional Tester (RFT).

Symptom

Browser enablement fails with the following info in the Details (Advanced) tab:

General Enablement Information
Bootstrap Loaded = true
Java2TestDomainImplementation Loaded = true
HtmlTestDomainImplementation Loaded = false
HtmlTestDomainImplementation Name = Unknown

Cause

One possible cause for the browser enablement to fail is that the registry key BrowseNewProcess is set to No.

    • With this key set to No, all opened Internet Explorer windows will use explorer.exe process instead of IEXPLORE.EXE for each browser window and that causes the browser enablement to fail.

Resolving The Problem

Procedure:

Disclaimer

This solution contains information about modifying the system registry. Before making any modifications to the Microsoft Registry Editor, it is strongly recommended that you make a backup of the existing registry. For more information describing how to back up the registry, refer to Microsoft Knowledge Base article 256986

Change the value of the registry key BrowseNewProcess to Yes.

  • User Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer\
    BrowseNewProcess]
  • Value Name: BrowseNewProcess
  • Data Type: REG_SZ (String Value)
  • Value Data: Yes

If the value is already set to Yes, contact Rational support for investigation to identify other causes of this issue.

[{"Product":{"code":"SSJMXE","label":"IBM Rational Functional Tester"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Test Environments","Platform":[{"code":"PF033","label":"Windows"}],"Version":"7.0;7.0.0.1;7.0.0.2;7.0.0.3;7.0.1;7.0.1.1;7.0.1.2;7.0.1.3;8.0","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21284563