IBM Support

IWAT0284E error at test connection to Agent Controller ports

Troubleshooting


Problem

Attempts to test the conncetion to the IBM Raional Performance Tester Agent in the preferences result in IWAT0284E error.

Symptom

Note
The test connection function does not apply to versions 8.3 and newer, Use the Agent Status button from the toolbar instead.

When testing the connection to the Rational Agent Controller port(s)s from Rational Performance Tester the following message appears.

IWAT0284E error during test connection to Agent Controller ports in Rational Performance Tester

Cause

The Integrated Agent Controller is enabled in Rational Performance Tester.

Resolving The Problem

Consider the following steps.

  1. Click Window -> Preferences > Agent Controller > Integrated Agent Controller.







  2. In the Settings tab disable (uncheck) the Enable check box

  3. Clickt the Apply button then the OK button.

  4. Close Rational Performance Tester.

  5. Reboot your workstation.

  6. Go to the Windows Control Panel -> Administrative tools -> Services

  7. Locate the IBM Rational Agent Controller; verify the following:
  • That the service is started
  • The path to the executable is correct
    default is C:\Program Files\IBM\SDP70Shared\AgentController\bin\ACWinservice.exe
  • Bring up Rational Performance Tester Go to Window -> Preferences -> Profile and logging -> Hosts. Perform a Test Connection on "localhost:10002"



[{"Product":{"code":"SSMMM5","label":"IBM Rational Performance Tester"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Agent Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.0;8.1;8.2","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21281597