IWAT0284E error during test connection to Agent Controller ports in Rational Performance Tester

Technote (troubleshooting)


Problem(Abstract)

This technote explains how to resolve an IWAT0284E error, that can occur when using IBM Raional Performance Tester.

Symptom

When testing the connection to the Rational Agent Controller port(s)s from Rational Performance Tester the following message appears:


    IWAT0284E error during test connection to Agent Controller ports in Rational Performance Tester

Cause

This can be caused when the Integrated Agent Controller is enabled in Rational Performance Tester.

Resolving the problem

To resolve this issue, perform the following steps:

  1. Bring up Rational Performance Tester and go to Window -> Preferences -> and expand the Agent Controller node and select Integrated Agent Controller.

  1. In the Settings tab disable (uncheck) the Enable check box
  2. Select the Apply button then the OK button.
  3. Exit out of Rational Performance Tester.
  4. Reboot your workstation.
  5. Go to the Windows Control Panel -> Administrative tools -> Services
  6. Locate the IBM Rational Agent Controller; verify the following:
  • That the service is started
  • The path to the executable is correct (default is C:\Program
    Files\IBM\SDP70Shared\AgentController\bin\ACWinservice.exe
    )
  • Bring up Rational Performance Tester Go to Window -> Preferences -> Profile and logging -> Hosts. Perform a Test Connection on "localhost:10002"

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Document information


More support for:

Rational Performance Tester
Agent Controller

Software version:

7.0, 7.0.0.1, 7.0.0.2, 7.0.1, 7.0.1.1, 7.0.2, 7.0.2.2, 7.0.2.3, 8.0

Operating system(s):

Windows

Reference #:

1281597

Modified date:

2008-03-08

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