Troubleshooting
Problem
When installing IDM Desktop, setup will prompt for a restart of the workstation. After the workstation starts up again, a window should pop up stating that it is registering DLLs. In rare situations, this step does not occur or does not complete successfully.
Symptom
The problem may first be noted when subsequently running IDM Configure. If the DLLs did not register, IDM Configure may suddenly terminate without error, or with the message:
Error in IDMcfg.exe
Cause
Security settings or currently running software may conflict with the installer's ability to set up or execute the post boot registration.
Diagnosing The Problem
In the Windows folder, locate the installation log called idmdesktop.log. The log should contain a section that looks like:
IDM post-reboot registration results:
Success: c:\windows\system32\atl.dll
Success: c:\windows\system32\atl.dll
Success: c:\filenet\idm\_w4wfwiz.dll
- .....
Success: c:\filenet\idm\fnacrobat.dll
IDM registration finished.
Resolving The Problem
To run the post boot installer manually:
- Navigate to the \Filenet\IDM folder.
- Run FnInstReg.exe.
- Recheck idmdesktop.log to confirm that it ran successfully.
Historical Number
10002853
Product Synonym
IDM DESKTOP
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Document Information
Modified date:
21 January 2022
UID
swg21274537