IBM Support

DLLs do not register after restarting IBM Filenet IDM Desktop when installing

Troubleshooting


Problem

When installing IDM Desktop, setup will prompt for a restart of the workstation. After the workstation starts up again, a window should pop up stating that it is registering DLLs. In rare situations, this step does not occur or does not complete successfully.

Symptom

The problem may first be noted when subsequently running IDM Configure. If the DLLs did not register, IDM Configure may suddenly terminate without error, or with the message:


    Error in IDMcfg.exe

Cause

Security settings or currently running software may conflict with the installer's ability to set up or execute the post boot registration.

Diagnosing The Problem

In the Windows folder, locate the installation log called idmdesktop.log. The log should contain a section that looks like:


    IDM post-reboot registration results:
    Success: c:\windows\system32\atl.dll
    Success: c:\windows\system32\atl.dll
    Success: c:\filenet\idm\_w4wfwiz.dll
      .....
    Success: c:\filenet\idm\fnacrobat.dll
    Success: c:\filenet\idm\fnacrobat.dll
    IDM registration finished.
If this section is missing, or shows that some DLLs failed to install, then manually rerun the post boot installer.

Resolving The Problem

To run the post boot installer manually:

  1. Navigate to the \Filenet\IDM folder.
  2. Run FnInstReg.exe.
  3. Recheck idmdesktop.log to confirm that it ran successfully.

[{"Product":{"code":"SS5USE","label":"IBM FileNet Web Services"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"IDM Desktop","Platform":[{"code":"PF033","label":"Windows"}],"Version":"4.0.2;4.0.1;4.0;3.3;3.2","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Historical Number

10002853

Product Synonym

IDM DESKTOP

Document Information

Modified date:
21 January 2022

UID

swg21274537