When installing the WebSphere Web services feature pack, some of its dependencies are not automatically indicated

Technote (troubleshooting)


Problem(Abstract)

The Web services feature pack is dependent on the WebSphere® Application Server development tools and WebSphere Application Server compile-time dependencies features. However, when the Web services feature pack is selected, the two features on which it depends might not be selected. This will also cause a "missing bundles" error message to display at the end of the installation.

Symptom

If you install the Web services feature pack without both the WebSphere Application Server development tools and WebSphere Application Server compile-time dependencies features, the following message will be seen at the end of the installation:

Problem during session finalization
Validation of Eclipse installation configuration failed because it has unsatisfied bundle constraints
Required bundle "com.ibm.ws.ast.facets.core" not found for bundle "com.ibm.ws.ast.wsfp.facets.core"
Required bundle "com.ibm.ws.ast.jythontools.ui" not found for bundle "com.ibm.ws.ast.jythontools.wsfp"
Required bundle "com.ibm.ast.ws.ui" not found for bundle "com.ibm.ast.ws.policyset.ui"
Required bundle "com.ibm.ws.ast.st.core" not found for bundle "com.ibm.ast.ws.jaxws.emitter"
Required bundle "com.ibm.ws.ast.st.core" not found for bundle "com.ibm.ast.ws.policyset.ui"
Required bundle "com.ibm.websphere.v61" not found for bundle "com.ibm.ast.ws.policyset.ui"
Required bundle "com.ibm.ws390.pmt" not found for bundle "com.ibm.ws390.pmt.wsfp"
Required bundle "com.ibm.ws390.pmt.config" not found for bundle "com.ibm.ws390.pmt.wsfp"
Required bundle "com.ibm.ws.ast.st.core" not found for bundle "com.ibm.ast.ws.jaxws.creation.ui"
Required bundle "com.ibm.ws.ast.st.core" not found for bundle "com.ibm.ast.ws.jaxws.samples"
Required bundle "com.ibm.ws.ast.st.v61.core" not found for bundle "com.ibm.ast.ws.policyset.ui"
Required bundle "com.ibm.websphere.v61.ext" not found for bundle "com.ibm.ws390.pmt.wsfp"
Required bundle "com.ibm.ws.pmt" not found for bundle "com.ibm.ws390.pmt.wsfp"


Resolving the problem

When installing the Web services feature pack, ensure that both the WebSphere Application Server development tools and WebSphere Application Server compile-time dependencies features are also selected.


To resolve the problem:

  1. If it is running, stop the workbench.
  2. Start IBM Installation Manager. (For example, on Windows operating systems click Start > All Programs > IBM Installation Manger > IBM Installation Manger.)
  3. Click Modify.
  4. On theModify Packages page, click the package group containing the product.
  5. Click Next.
  6. On the first Features page (language selection), click Next.
  7. On the second Features page, select the following things:
  • WebSphere Application Server development tools
  • WebSphere Application Server compile-time dependencies
    1. Click Next.
    2. Click Modify.

Cross Reference information
Segment Product Component Platform Version Edition
Software Development Rational Software Architect Install / Migration Linux, Windows 7.0.0.3, 7.0.0.4, 7.0.0.5, 7.0.0.6, 7.0.0.7

Rate this page:

(0 users)Average rating

Document information


More support for:

Rational Application Developer for WebSphere Software
Installation

Software version:

7.0.0.7

Operating system(s):

Linux, Windows

Reference #:

1272121

Modified date:

2008-03-27

Translate my page

Machine Translation

Content navigation