Technote (troubleshooting)
Problem
When an anonymous user navigates to Web Content Management™ (WCM) content and then logs into the IBM WebSphere Portal® server, the user is redirected to a WCM URL instead of the standard redirection to a protected page in WebSphere Portal.
Cause
Using the protected URL /myconnect from the public space.
Diagnosing the problem
-- Collect HTTP header logging.
-- Collect Engine tracing.
Resolving the problem
The HTTP header logging and Engine tracing shows that the "rightlinks_back.gif" image in one of the public JSPs is included in the protected scope:
GET /wps/wcm/myconnect/c7b3f680452d8d03ab38ffe1318cc2ca/rightlinks_back.gif? MOD=AJPERES&CACHEID=c7b3f680452d8d03ab38ffe1318cc2ca
For JSPs that run in the public space, the URL to load static content should be loaded from the public context as well. This must be corrected in the JSP tag that includes this image file. After making the correction, "anonymous" will be redirected to the protected Portal page when logging into WebSphere Portal after browsing the public WCM content.
The HTTP header log will now show:
GET /wps/wcm/connect/c7b3f680452d8d03ab38ffe1318cc2ca/rightlinks_back.gif? MOD=AJPERES&CACHEID=c7b3f680452d8d03ab38ffe1318cc2ca
Rate this page:
Copyright and trademark information
IBM, the IBM logo and ibm.com are trademarks of International Business Machines Corp., registered in many jurisdictions worldwide. Other product and service names might be trademarks of IBM or other companies. A current list of IBM trademarks is available on the Web at "Copyright and trademark information" at www.ibm.com/legal/copytrade.shtml.