IBM Support

UCM ClearQuest and ClearCase Integration error: Unable to logon to ClearQuest user database dbName

Troubleshooting


Problem

This technote identifies how to resolve the error, Unable to logon to ClearQuest user dbName, which might occur when attempting to set to an activity from a check-in or check-out, or to add to source control when using an UCM enabled IBM® Rational® ClearQuest and IBM Rational ClearCase® integration.

Cause

The full error message is as follows:


Unable to logon to ClearQuest user database "dbName".

The logs might also have recorded the following error:

SQUID_AD COM exception: [../squid_adsession.cxx/line 746]:
Server execution failed.

One possible causes for this issue is the Microsoft® Windows® environment variables might not contain entries for theses Rational products.

Resolving The Problem

To check to see if the environment variables are correct you will need to run the command set from a command prompt.

For example:

  1. Navigate to Start, Run and type in cmd
  2. Type in set
    The output will be similar to the following:

    ATRIAHOME=C:\Program Files\Rational\ClearCase
    IBMLDAP_ALTHOME=C:\Program Files\Rational\common\codeset
    Path=C:\WINDOWS\system32;<...>C:\Program files\Rational\ClearCase\bin;C:\Program Files\Rational\common;

If the above environment variables are not set correctly, you will need to run a repair on the installation for both ClearCase and ClearQuest.
  1. Navigate to Start > Settings > Control Panel > Add or Remove Programs.
  2. Once Add or Remove Programs opens, in the list you should see ClearQuest and ClearCase.
    Note:
    If you installed ClearQuest using the IBM Rational Suite® Install, then you may see Rational Suite in the Add/Remove programs list instead.
  3. Select Change and then Repair.
    Note: You will need to perform this repair for both ClearCase and ClearQuest.
  4. Once both ClearCase and ClearQuest are repaired, the missing environment paths should now be present. Verify this by running the set command again.

[{"Product":{"code":"SSSTXH","label":"Rational Integrations"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"UCM ClearCase and ClearQuest","Platform":[{"code":"PF033","label":"Windows"}],"Version":"2003.06.00;2003.06.01;2003.06.10;2003.06.12;2003.06.13;2003.06.14;2003.06.15;2003.06.16;7.0;7.0.0.1;7.0.1","Edition":"","Line of Business":{"code":"","label":""}},{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":" ","Platform":[{"code":"PF033","label":"Windows"}],"Version":"","Edition":"","Line of Business":{"code":"LOB36","label":"IBM Automation"}},{"Product":{"code":"SSSH5A","label":"Rational ClearQuest"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":" ","Platform":[{"code":"PF033","label":"Windows"}],"Version":"","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21267128