IBM Support

Inability to create Dynamic Views with MVFS installed and missing MVFS tabs

Troubleshooting


Problem

This technote provides you with information about IBM® Rational® ClearCase® and why a user may be unable to create a dynamic view on Microsoft® Windows® when the MVFS is installed.

Symptom

Attempts to create a view using the View Creation Wizard does not reveal an option to create a dynamic view. The dynamic view radio button is not seen or is disabled so it cannot be selected.

Cause

  1. Typical cause is that the ClearCase was corrupted somewhere during the installation process.
  2. There is one known case where a corrupt installation was not the cause. It was determined in this case that the Credentials Manager Service was stopped. This service has been manually set from its default Automatic Start-up status to a Manual Start-up status. When this service is stopped, the MVFS tabs in ClearCase Properties in Control Panel will not be present and thus will affect the creation of dynamic views.
  3. This problem can also occur if running ClearCase on Windows Vista™ that is not running the supported ClearCase patch level.

Resolving The Problem

Solution 1

If this problem only occurs on one machine, you may have a bad installation. Uninstall and reinstall ClearCase

Solution 2

Start the Credentials Manager Service (if it is stopped).

You can verify if the Credentials Manager from the ClearCase Control Panel on the Services Startup tab.

If the Credentials Manager is stopped, start it from the command line using the following command:


net start cccredmgr

Note: Also ensure that the Credentials Manager Service is set to an Automatic startup. Open the Windows Control Panel (Click Start > (Settings) > Control Panel) and navigate to Services. Open the Rational Cred Manager service to check the Start-up type.

If the Credentials Manager Service is started, verify if the problem is occurring on more than one machine.

  • If the problem only occurs on the one machine, you will need to uninstall and reinstall as often times this is a problem with a ClearCase installation being corrupt or not having the correct privileges to install correctly.
  • If this problem occurs on more than one machine, contact support for assistance.

Solution 3


If running Windows Vista, review technote 1239315 for a list of supported releases and patch level requirements.

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Document Information

Modified date:
16 June 2018

UID

swg21266435