Troubleshooting
Problem
This technote explains why the error []Interactive triggers are not supported in the Web interface[] might occur when using non-interactive triggers with the IBM® Rational® ClearCase® Remote Client (CCRC) or ClearCase Web client (CCWeb).
Symptom
Error reported when a trigger fails while using either a CCRC or ClearCase WEB (CCWeb) client:
Interactive triggers are not supported in the Web interface.
If the trigger was interactive, it may have failed for that reason.
Cause
- CCRC
An error in the trigger script makes CCRC think the trigger is interactive. Below are 2 scenarios that will cause this error.
- The trigger used to generate the error below did not include the full file system path to cqperl in the script which caused the script to require input thus making the non-interactive script, interactive.
An example of the full error message:
ccweb: Warning: Trigger "Deliver_CQRequired" has refused to let deliver_start proceed.
Interactive triggers are not supported in the Web interface.
If the trigger was interactive, it may have failed for that reason.
- The trigger script was referencing a user defined environment variable which was set on the client but could not be found on the RWP web server.
In this example the user defined environment variable MYCC_TRIGGER_TMP was set on the client to define an alternate temp directory and is referenced by the trigger script. However, it was not defined on the RWP web server.
An example of the full error message:
Unable to checkin "<path to file>"
Error: directory for environmentvariable "MYCC_TRIGGER_TMP" or "TMP" not found
ccweb: Warning: Trigger "ci_pre" has refused to let checkin proceed.
Interactive triggers are not supported in the Web interface.
If the trigger was interactive, it may have failed for that reason.
ccweb: Error: Unable to check in "<path to file>".
- CCWeb
ClearCase always displays that message when a trigger script fails or fails to execute. ClearCase can find the trigger, however, it can't find the trigger script.
Resolving The Problem
HINT: Trigger scripts should be carefully tested to ensure that they are properly structured and functional for your environment.
Solution 1:
- Update the trigger script to include the full file system path to cqperl.
- You must define the environment variable on the RWP web server in the ccweb.conf file and rwp.conf (or rwp_startup) scripts.
Examples:
In /var/adm/rational/common/rwp/conf/ccweb.conf
- <Location /ccweb>
DirectoryIndex bin/ccweb
...
# This passes the LANG environment var to allow the ccweb CGI program
# to correctly get the locale.
PassEnv LANG
PassEnv NLSPATH
PassEnv MYCC_TRIGGER_TMP
</Location>
In /var/adm/rational/common/rwp/conf/rwp_startup or rwp.conf
# Assume success to begin with
# Ensure an appropriate path. On Linux, standard UNIX executables like ls and rm
# are typically in /bin, whereas on Solaris, HP-UX, and AIX they are
# typically in /usr/bin. We put both on the path. We also put
# the system /sbin and /usr/sbin on the path.
PATH=/org/st32/log2_snapshot/advantage/tooling/cm/cc_trigger:/bin:/usr/bin:/sbin:/usr/sbin:$PATH
export PATH
MYCC_TRIGGER_TMP=/var/tmp
export MYCC_TRIGGER_TMP
Refer to technote 1207634 Writing triggers for the ClearCase Remote Client for further information.
Solution 2:
You need to specify a path for the trigger script that can be easily located. The script isn't aware of the CCWeb view that you are using on the client system, thus scripts located inside VOBs or only on the VOB server cannot be located from the view or RWP server.
The trigger is run from the view or RWP server and the path specified in the script must be one that can be located from the view server. If the view server is a UNIX® or Linux® system, then it is the -execunix phrase that fires.
Review the ClearCase Command Reference Guide on the topic of mktrtype (cleartool man mktrtype) for more information.
[{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"ClearCase Remote Client","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF015","label":"IRIX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"2003.06.14;2003.06.15;2003.06.16;7.0;7.0.0.1;7.0.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}},{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"ClearCase Web (CCWeb)","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]
Was this topic helpful?
Document Information
Modified date:
16 June 2018
UID
swg21266044