IBM Support

Technote (troubleshooting)


Problem(Abstract)

How to set JVM in WebSphere Partner Gateway

Cause

The following is the method of setting JVM in WebSphere Partner Gateway:

(This can be helpful when customer is receiving out of memory error)


Resolving the problem

Instructions to Set the JVM settings,


Step 1 : Start the bcgdocmgr

Step 2 : Open the command prompt or shell( Make sure below steps are
carried out in the same command prompt)

Step 3 : If unix system(AIX,Solaris,Suse and linux) then Change the user
to "bcguser".
For Windows system ignore Step 3.

Step 4 : change directory to
"<installed_path>/bcghub/was/profiles/bcgdocmgr/bin"

Step 5 : execute "setupCmdLine.bat" or "./setupCmdline.sh"

Step 6 : Execute,
Syntax,
"wsadmin -conntype NONE -f
<installed_path>/bcghub/scripts/bcgSetJVMHeapAttrs.jacl <initial heap
size> <Maximum heap size> bcgdocmgr DefaultNode"

Say For Windows system,
"wsadmin -conntype NONE -f
<installed_path>/bcghub/scripts/bcgSetJVMHeapAttrs.jacl 512 1024
bcgdocmgr DefaultNode"

Say For Unixs system,
"./wsadmin.sh -conntype NONE -f
<installed_path>/bcghub/scripts/bcgSetJVMHeapAttrs.jacl 512 1024
bcgdocmgr DefaultNode"

Step 7 :Restart the bcgdocmgr


Cross reference information
Segment Product Component Platform Version Edition
Business Integration WebSphere Partner Gateway - Express 6.0.0, 6.0.0.1, 6.0.0.2, 6.0.0.3, 6.0.0.4, 6.0.0.5 All Editions
Business Integration WebSphere Partner Gateway Enterprise Edition 6.0.0, 6.0.0.1, 6.0.0.2, 6.0.0.3, 6.0.0.4, 6.0.0.5 All Editions

Document information

More support for: WebSphere Partner Gateway Advanced Edition

Software version: 6.0.0.1, 6.0.0.2, 6.0.0.3, 6.0.0.4, 6.0.0.5, 6.0.0.6, 6.0.0.7

Operating system(s): Linux, Windows

Software edition: All Editions

Reference #: 1258461

Modified date: 2011-03-07