Troubleshooting
Problem
This technote identifies an issue where Floating License Keys are not released by IBM® Rational® applications such as IBM Rational ClearQuest® when the License Server is hosted on Microsoft® Windows®.
Cause
This issue has been seen only with floating keys and most often IBM Rational ClearQuest keys. When a client logs off the License Server holds onto the key and does not return it to the keys pool.
Resolving The Problem
The following procedure has you apply a fix to the License Server to resolve the issue:
Note: You will need administrative access to the License server to apply the fix.
On the License Server:
- Access Start > Run... and enter the following command:
c:\program files\rational\common\lmtools.exe
- Once the lmtools dialog box opens, Stop the Flexlm License Manager Service
- Exit lmtools
- Create backup copies of the lmgrd.exe, lmtools.exe, lmutil.exe and rational.exe, which are located in the following directory:
c:\program files\rational\common\
- Download and extract the following files to the c:\program files\rational\common\ directory:
- Access Start > Run... and enter the following command:
c:\program files\rational\common\lmtools.exe
- Once the lmtools dialog box opens, Start the Flexlm License Manager Service
[{"Product":{"code":"SSTMW6","label":"Rational License Key Server"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Configuration","Platform":[{"code":"PF033","label":"Windows"}],"Version":"2003.06.13;2003.06.14;2003.06.15;2003.06.16;7.0;7.0.0.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]
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Document Information
Modified date:
16 June 2018
UID
swg21254476