IBM Support

Setup Halted, after beginning ClearQuest installation

Troubleshooting


Problem

When launching the installation program for IBM® Rational® ClearQuest® on Microsoft® Windows® operating systems, a Setup Halted message can occur.

Symptom

It is possible that the installation will stop shortly after initializing. It will simply display a Setup Halted message with a Finish button. No status bar appears at all, and there is no prompt for a user agreement.

Check the rational_eventhandler.log, found in the TEMP directory. The location of the directory depends on the TEMP environment user variable set on the computer. To find the location, open a Windows command prompt window and type echo %TEMP%

Look for this error:

User Did NOT Accept License Agreement or a LAP tool Error was encountered
See nRet value from _launchLAPTool above -- Install terminating

Cause


It has been observed that security settings and pop-up blocking procedures in Microsoft® Internet Explorer® can interfere with the installation process. Certain aspects of the installation program, such as the Rational License Agreement, are web-based. Even if pop-up blocking is disabled and security settings lowered, Internet Explorer could interpret the process as a pop-up or security issue. The applicable anti-virus on the computer, as well as any additional spy ware, adware, and pop-up blocking applications on the computer can also cause this

Here are additional problems known to cause this::

  • User security restriction on the computer could be preventing the installation on the computer from executing properly if a nonlocal or non-administrator account is being used to launch.
  • It is possible there is corruption or invalid data in the install script. For example, there might be a special character in the installation path that cannot be interpreted by the installer.
  • Local installation files are incomplete, or corrupted.

Resolving The Problem

These activities can be performed to troubleshoot this problem:

  • Try disabling the pop-up blocking capability of Internet Explorer, or lower its security levels if they are currently set to higher levels.
  • Verify that there are no special characters such as "!" or "?" in the installation path for the script.
  • If Internet Explorer is the default web browser, try setting Firefox as the default browser for the installation process.
  • As proposed when the installation of the program is in progress, the anti-virus program needs to be disabled. Additionally, pop-up blockers, adware/spyware scanners, and/or other supplemental security programs may need to be disabled to assure that the installation program runs properly.
  • In order to assure proper installation, please execute the installation program as a Local, Administrative user for the operating system.
  • Attempt to re-install the install script:
    1. In the installation folder, go to the ../disk1/setup directory
    2. There should see the file isscript1050.msi
    3. If this file is remote, copy it to a location on the computer
    4. In a command line window, navigate to the directory that isscript1050 is in.
    5. Run the command

      msiexec /x isscript1050.msi


      This should uninstall the scripting engine.
    6. Run the command

      msiexec /i isscript1050.msi /lv* C:\scriptLog.log


      This will reinstall InstallShield. At the end of the log, If you see the message "Installation operation completed successfully", then its validated that the reinstall is complete.
    7. At this point, attempt to reinstall ClearQuest.
  • If performing a local (Enterprise CD) installation, re-download and extract the installation files to verify that there are no missing or corrupted files. If possible, compare the download area with that of one that was successful in resolving the problem for size verification.

[{"Product":{"code":"SSSH5A","label":"Rational ClearQuest"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Installation","Platform":[{"code":"PF033","label":"Windows"}],"Version":"2003.06.16;7.0;7.0.0.1;7.0.0.2;7.0.0.3;7.0.0.4;7.0.0.5;7.0.0.6;7.0.0.7;7.0.0.8;7.0.0.9;7.0.1;7.0.1.1;7.0.1.2;7.0.1.3;7.0.1.4;7.0.1.5;7.0.1.6;7.0.1.7;7.0.1.8","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}},{"Product":{"code":"SSCTQH","label":"Rational Common Components"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Rational Common Installer","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"","label":""}}]

Document Information

Modified date:
16 June 2018

UID

swg21251381