Supported Software for CICS Transaction Gateway (CICS TG) v7.0

Technote (FAQ)


Question

This document lists the IBM and third party software supported for use with the CICS Transaction Gateway (CICS TG) v7.0 both for multiplatforms and for z/OS

Answer

This page provides on-line information about the levels of third-party software that run with CICS TG and supersedes information in the relevant announcement letters and Administration Guide.

Minimum requires service levels are listed below where appropriate. Where no specific level is listed, support will be provided for the General Availability (GA) release of the third-party product. CICS TG is not tested with every maintenance level of every product; we generally assume vendors do not cause regressions in their maintenance levels.

Products that do not appear below have not been tested with CICS TG v7.0.

Note: Because interaction between releases of operating systems, software products, and CICS TG is very complex, information on this page can possibly conflict with information that is provided by product vendors. If you notice such an inconsistency or if you experience unanticipated problems, consult your vendor's product support and notify your IBM support representative.

Footnotes can be found directly below the table to which they apply.


For End Of Service information, refer to the Product support lifecycle page.


Operating Systems

Product
Minimum Service Level
Notes
Windows 2000 Professional SP4
Windows 2000 Server SP4
Windows 2000 Advanced Server SP4
Windows XP Professional SP2 64-bit version is not supported
Windows Server 2003 Standard Edition 64-bit version is supported
2003 R2 is supported
Windows Server 2003 Datacenter Edition 64-bit version is supported
2003 R2 is supported
Windows Server 2003 Enterprise Server 64-bit version is supported
2003 R2 is supported
Windows Vista (Business, Enterprise, Ultimate editions)(2) 64-bit version is not supported
AIX v5.2 Supported as a 32-bit application on both 32-bit and 64-bit kernels
AIX v5.3 Supported as a 32-bit application on both 32-bit and 64-bit kernels
AIX v6.1 Supported as a 32-bit application on both 32-bit and 64-bit kernels
Solaris 9 Supported as a 32-bit application on both 32-bit and 64-bit kernels.
Supported on SPARC systems only
Solaris 10 Supported as a 32-bit application on both 32-bit and 64-bit kernels.
Supported on SPARC systems only
HP-UX 11i v2 (on PA-RISC) Supported as a 32-bit application on both 32-bit and 64-bit kernels.
HP-UX 11i v2 (on Itanium) (2) Supported as a 32-bit application on both 32-bit and 64-bit kernels.
RHEL 3 (Linux on Intel) (1) Update 6 Supported as a 32-bit application on the 32-bit kernel
RHEL 4 (Linux on Intel) (1) Update 2 Supported as a 32-bit application on the 32-bit kernel
RHEL 5 (Linux on Intel) (2) Supported as a 32-bit application on the 32-bit kernel.
SLES 9 (Linux on Intel) (1) SP2 Supported as a 32-bit application on the 32-bit kernel.
SLES 10 (Linux on Intel) Supported as a 32-bit application on the 32-bit kernel.
RHEL 3 (Linux on POWER) (1) Update 6 Supported as a 32-bit application on the 64-bit kernel.
RHEL 4 (Linux on POWER) (1) Update 4 Supported as a 32-bit application on the 64-bit kernel.
RHEL 5 (Linux on POWER) (2) Supported as a 32-bit application on the 64-bit kernel.
SLES 9 (Linux on POWER) (1) Supported as a 32-bit application on the 64-bit kernel.
SLES 10 (Linux on POWER) Supported as a 32-bit application on the 64-bit kernel.
RHEL 3 (Linux on zSeries) (1) Update 6 Supported as a 31-bit application on the 31-bit kernel
RHEL 4 (Linux on zSeries) (1) Supported as a 31-bit application on the 64-bit kernel
RHEL 5 (Linux on zSeries) (2) Supported as a 31-bit application on the 64-bit kernel
SLES 9 (Linux on zSeries) (1) Supported as a 31-bit application on the 64-bit kernel.
SLES 10 (Linux on zSeries) Supported as a 31-bit application on the 64-bit kernel.
z/OS 1.6 z/OS.e is supported only for Java client remote mode and WebSphere Application Server support. You can not install the CICS TG on the z/OS.e operating system
z/OS 1.7 APAR OA14310 required for WLM health reporting
APAR OA08988 required for RACF mixed case password support
APAR OA18747 required to prevent delayed shutdown
z/OS.e is supported only for Java client remote mode and WebSphere Application Server support. You can not install the CICS TG on the z/OS.e operating system
z/OS 1.8 z/OS.e is supported only for Java client remote mode and WebSphere Application Server support. You can not install the CICS TG on the z/OS.e operating system
z/OS 1.9
z/OS 1.10
z/OS 1.11
1) Both NPTL and LT threading models are supported, however, NPTL may provided better performance
2) CICS TG v7.0.1 required


J2EE Application Servers
Product
Minimum Service Level
Notes
WebSphere Application Server v7 for z/OS (31-bit and 64-bit) Java5 SR5 available in V6.1.0.9 required Supported in remote and local mode
WebSphere Application Server v6.1 for z/OS (64-bit) Java5 SR3 available in V6.1.0.3 required
APAR PK29562 required for Java 2 security
Supported in remote and local mode
WebSphere Application Server v6.1 for z/OS (31-bit) Java5 SR3 available in V6.1.0.3 required
APAR PK29562 required for Java 2 security
Supported in remote and local mode
WebSphere Application Server v6.0.1 for z/OS (31-bit) APAR PK29562 required for Java 2 security usage Supported in remote mode only, using the CICS TG V6 JCA 1.5 resource adapters connecting to CICS TG v7.0 (4)
RAR 6.1.0.1 or 6.0.2.1 required for Java2 security
WebSphere Application Server v5.1 for z/OS (31-bit) Supported in remote mode only, using the CICS TG V5.1 JCA 1.0 resource adapters connecting to CICS TG v7.0 (4)
RAR 5.1.0.2 required for Java2 security
WebSphere Application Server v7 (32-bit and 64-bit)(3) 64-bit version supported in remote mode only for all protocols
WebSphere Application Server v6.1 (64-bit) (3) Java5 SR3 available in V6.1.0.3 required
APAR PK29562 required for Java 2 security usage
Supported in remote mode only.
WebSphere Application Server v6.1 (32-bit) (3) Java5 SR3 available in V6.1.0.3 required
APAR PK29562 required for Java 2 security usage
Supported in remote and local mode.
WebSphere Application Server v6.0 (32-bit) (3) APAR PK12240 required to resolve an exception chaining issue to aid in problem determination(5)
APAR PQ99940 required to resolve a connection pooling problem after a StaleConnectionException is received
APAR PK29562 required for Java 2 security usage
Supported in remote mode only, using the CICS TG V6 JCA 1.5 resource adapters connecting to CICS TG v7.0 (4)
RAR 6.1.0.1 or 6.0.2.1 required for Java2 security
WebSphere Application Server v5.1 Supported in remote mode only using the CICS TG v5.1 JCA 1.0 resource adapters connecting to CICS TG v7.0 (4).
RAR 5.1.0.2 required for Java2 security
Weblogic Application Server v8.1 SP5 Supported in remote mode only using the CICS TG v5.1 JCA 1.0 resource adapters connecting to CICS TG v7.0 (4)
RAR 5.1.0.2 required
3) This includes versions running on the Windows, AIX, Solaris, Linux on Intel, Linux on zSeries, Linux on POWER, HP-UX/RISC and HP-UX/Itanium operating systems
4) Licensed CICS TG users can obtain the latest supported CICS JCA resource adapters using SupportPac CC03 available at: http://www.ibm.com/support/docview.wss?uid=swg24008817
5) Refer to Websphere Application Server APAR PK12240 for further information.
6) Refer to http://www-1.ibm.com/support/docview.wss?uid=swg1PK29562 for further information.


SNA Servers
Product
Minimum Service Level
Notes
Microsoft Host Integration Server 2000 SP1
Microsoft Host Integration Server 2004
IBM Communications Server v6.2 for Linux on zSeries
IBM Communications Server v6.2 for Linux Includes Linux on Intel and Linux on POWER support
IBM Communications Server v6.3 for AIX
IBM Communications Server v6.1 for Windows Windows API client requires fix to APAR LI71318
IBM Personal Communications v5.9 for Windows(7)
IBM Personal Communications v5.8 for Windows
IBM Personal Communications v5.7 for Windows
SNAP-IX V7 for Solaris
7) CICS TG v7.0.1 required

CICS Servers
Product
Minimum Service Level
Notes
CICS TS for z/OS v2.2 APARs PQ75803 & PQ82124 (required for TCP/IP)
APAR PQ70543 (required for terminal recovery)
APAR PK17427(required for transactional EXCI)
Apply APAR PQ92943 for improved EXCI scalability
Apply APAR PK08496 for mixed case password support
CICS TS for z/OS v2.3 APARs PQ81772 & PQ82124 (required for TCP/IP)
APAR PK17427(required for transactional EXCI)
Apply APAR PQ92943 for improved EXCI scalability
Apply APAR PK08496 for mixed case password support
CICS TS for z/OS v3.1 APAR PK17426 (required for transactional EXCI)
CICS TS for z/OS v3.2 and later( 8)
CICS/VSE v2.3 APAR PQ30169 (required for signon capable terminals)
CICS TS for VSE/ESA v1.1.1 APARs PQ52342 & PQ80212 (required for TCP/IP)
APAR PQ30170 (required for signon capable terminals)
CICS TS for iSeries v5.1
CICS TS for iSeries v5.2
CICS TS for iSeries v5.3
TXSeries v5.1
TXSeries v6.0
TXSeries v6.1
TXSeries v6.2
TXSeries v7.1
CICS TS for Windows v5.0
8) CICS TG v7.0.1 required

Application Development Tools and Compilers
Platform
Development Language
C/C++
Others
Windows Microsoft Visual C++ .NET 2003 (9)
Microsoft Visual C++ 2005
COBOL:
IBM COBOL for Windows V7, Supplied with IBM WebSphere Developer for System z v7.0
IBM COBOL for Windows V6, Supplied with IBM WebSphere Developer for System z v6.0
Micro Focus Net Express v4.0
IBM WebSphere Studio COBOL for Windows v5.1.1, supplied with WSED
IBM COBOL for Windows 6.0.1 supplied with WD4Z v6.0
Micro Focus Net Express v3.1
Micro Focus Net Express v4.0
Visual Basic:
Visual Basic .NET Standard 2003 (9,10)
Microsoft Visual Basic Script (VBScript) v5.6
AIX IBM C for AIX v6.0
IBM VisualAge C++ Professional for AIX v6.0
XL C/C++ Enterprise Edition V7.0 for AIX
XL C/C++ Enterprise Edition V8.0 for AIX
IBM COBOL compiler for AIX v2.0
Micro Focus Server Express V5.0, COBOL compiler for AIX
Micro Focus Server Express V4.0, COBOL compiler for AIX
Solaris Sun ONE Studio 9
Sun ONE Studio 10
Sun ONE Studio 11
Micro Focus Server Express V5.0, COBOL compiler for Solaris
HP-UX aC++ compiler
ANSI C compiler
Micro Focus Server Express V5.0, COBOL compiler for HP-UX
Linux on POWER GNU C/C++ compiler (gcc) 3.2, 3.3 or 3.4
XL C/C++ Enterprise Edition V7.0 for Linux
XL C/C++ Enterprise Edition V8.0 for Linux
Micro Focus Server Express V5.0, COBOL compiler for Linux on POWER
Linux on Intel GNU C/C++ compiler (gcc) 3.2, 3.3 or 3.4 Micro Focus Server Express V5.0, COBOL compiler for Linux on Intel
Linux on zSeries GNU C/C++ compiler (gcc) 3.2, 3.3 or 3.4 Micro Focus Server Express V5.0, COBOL compiler for Linux on zSeries
z/OS z/OS V1R6 C/C++
z/OS V1R7 XL C/C++
z/OS V1R8 XL C/C++
9) Supported to produce unmanaged code
10) The CICS Transaction Gateway does not support the use of COM libraries with Microsoft Transaction Server (MTS), or the MTS component of COM+

Java Platforms
Gateway Daemon
Platform
SDK Version
Notes
Windows IBM 32-bit Runtime Environment for Windows, Java 2 Technology Edition, Version 5.0 SR3
AIX IBM 32-bit Runtime Environment for AIX, Java 2 Technology Edition, Version 5.0 SR3
Solaris IBM 32-bit Runtime Environment for Solaris, Java 2 Technology Edition, Version 5.0 SR3
HP-UX (on PA-RISC) HP 32-bit Runtime Environment for J2SE HP-UX 11i platform, adapted by IBM for IBM software, Version 5.0 SR3
HP-UX (on Itanium)(13) HP 32-bit Runtime Environment for J2SE HP-UX 11i platform, adapted by IBM for IBM software, Version 5.0 SR3
Linux on POWER IBM 32-bit Runtime Environment for Linux on iSeries and pSeries, Java 2 Technology Edition, Version 5.0 SR3
Linux on Intel IBM 32-bit Runtime Environment for Linux on Intel architecture, Java 2 Technology Edition, Version 5.0 SR3
Linux on zSeries IBM 31-bit Runtime Environment for Linux on zSeries architecture, Java 2 Technology Edition, Version 5.0 SR3
z/OS IBM 31-bit Runtime Environment for z/OS architecture, Java 2 Technology Edition, Version 5.0 SR5
Gateway Classes
Platform
SDK Version
Notes
Windows IBM 32-bit SDK for Windows, Technology Edition, Version 5.0
IBM 64-bit SDK for Windows, Technology Edition, Version 5.0(11)
64-bit JVM supported in remote mode only
AIX IBM 32-bit SDK for AIX, Technology Edition, Version 5.0
IBM 64-bit SDK for AIX, Technology Edition, Version 5.0 (11)
64-bit JVM supported in remote mode only
Solaris IBM 32-bit SDK for Solaris, Technology Edition, Version 5.0
HP-UX (on PA-RISC) HP 32-bit SDK for J2SE HP-UX 11i platform, adapted by IBM for IBM Software, Version 5.0
HP-UX (on Itanium)(12) HP 32-bit SDK for J2SE HP-UX 11i platform, adapted by IBM for IBM Software, Version 5.0
HP 64-bit SDK for J2SE HP-UX 11i platform, adapted by IBM for IBM Software, Version 5.0 (11)
64-bit JVM supported in remote mode only
Linux on POWER IBM 32-bit SDK for Linux on iSeries and pSeries, Technology Edition, Version 5.0
IBM 64-bit SDK for Linux on iSeries and pSeries, Technology Edition, Version 5.0 (11)
64-bit JVM supported in remote mode only
Linux on Intel IBM 32-bit SDK for Linux on Intel architecture, Technology Edition, Version 5.0
IBM 64-bit SDK for Linux on AMD64/EM64T architecture, Technology Edition, Version 5.0 (11)
64-bit JVM supported in remote mode only
Linux on zSeries IBM 31-bit SDK for Linux on zSeries architecture, Technology Edition, Version 5.0
IBM 64-bit SDK for Linux on zSeries architecture, Technology Edition, Version 5.0 (11)
64-bit JVM supported in remote mode only
z/OS IBM 31-bit SDK for z/OS, Technology Edition, Version 5.0
IBM 64-bit SDK for z/OS, Technology Edition, Version 5.0
64-bit JVM supported in local and remote mode
11) Supported only under WebSphere Application Server v6.1, for connectivity to a remote Gateway daemon
12) CICS TG v7.0.1 required


Other
Product
Minimum Service Level
Notes
JAWS screen reader v6.0
Citrix Presentation Server v4.0 Supported on Microsoft Windows Server 2003, and Windows 2000 Server
Tivoli System Automation for z/OS V3.1 APAR OA18621 required for CICS TG support

Rate this page:

(0 users)Average rating

Document information


More support for:

CICS Transaction Gateway
Installation

Software version:

7.0

Operating system(s):

AIX, HP-UX, Linux, Solaris, Windows, z/OS

Reference #:

1250788

Modified date:

2010-01-14

Translate my page

Machine Translation

Content navigation