Troubleshooting
Problem
Your JMS application runs on IBM® WebSphere® Application Server to connect to a WebSphere MQ messaging system receives an MQJMS2005 error with reason code 2059.
Cause
Reason code 2059 means that the queue manager is not available.
The most likely cause of the problem is that the queue manager is not running or that the queue manager listener is not running. Another possible cause is that the queue manager name that is specified on the JMS connection factory is incorrect.
Resolving The Problem
These are some steps to take to try to resolve the cause of the 2059 error.
Confirm that the queue manager is up and running and that the listener is running
- Ensure that the queue manager is running. You can use the dspmq command to verify this. The status of the queue manager should be Running.
- Check the MQ FDC files in the MQ_install_root/errors and MQ_install_root/qmgrs/queue_manager_name/errors directories to see what relevant error messages may be logged there.
- Check that the queue manager is the default queue manager. If there is no default queue manager, then define one. This can be set in the mqs.ini file. See the WebSphere MQ System Administration Guide for more information.
- Ensure that the queue manager has a listener running and is listening on the right port.
Start the listener program using the following command:
runmqlsr -t tcp -p <port_number> -m <qmgr_name>
Other possible causes for the reason code 2059
If you are using the CLIENT transport type to connect to the queue manager on an IPv4/IPv6 dual stack machine -- for example, SLES 9 and Redhat Enterprise Linux® 4 -- and you use "localhost" as the queue manager name. Either use the machine name or ip address instead of "localhost" or set:
-Djava.net.preferIPv4Stack=true
If you set the CCSID, then check this technote.
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Document Information
Modified date:
15 June 2018
UID
swg21249782