Troubleshooting
Problem
When using SCP to copy files to or from the WebSphere DataPower device, if there is an error, the only response you will get is the following: % Copy: File not found File copy failed
Cause
The SSH implementation on the DataPower system will not extract more information from the SSH service if there is a failure such as invalid username, password, filenames, connection failures, etc.
Resolving The Problem
Using other protocols such as HTTP to transfer the files will return errors with more information should there be a problem. For example:
Also, refer to the CLI Reference Guide and to the CLI on-line help for information of supported transfer protocols and command syntax.
If further help is needed, collect the following information and contact IBM DataPower support:
- Example of the file named "file" not being within that users directory:
idg(config)# copy scp://username:password@hostname.com/file temporary:file
% Copy: File not found
File copy failed
- Example of the file "file.txt" that is not readable:
idg(config)# copy scp://username:password@hostname.com/file.txt temporary:file.txt
% Copy: File not found
File copy failed
- Example of the server connection fails or connection fails:
idg(config)# copy scp://username:password@hostname.com/file.txt temporary:file.txt
% Copy: File not found
File copy failed
|
Also, refer to the CLI Reference Guide and to the CLI on-line help for information of supported transfer protocols and command syntax.
If further help is needed, collect the following information and contact IBM DataPower support:
- Set the log level to debug to reproduce the failure and collect all logs from the logtemp:// directory from the device.
- A packet trace running at the time of the failure will also help if it is possible to collect one.
[{"Type":"SW","Line of Business":{"code":"LOB45","label":"Automation"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Product":{"code":"SS9H2Y","label":"IBM DataPower Gateway"},"ARM Category":[{"code":"a8m50000000CdrrAAC","label":"DataPower->MGMT (MM)->CLI"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Version(s)"}]
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Document Information
Modified date:
21 April 2021
UID
swg21248865