Troubleshooting
Problem
This technote identifies a set of both IBM® Rational® ClearCase® errors as well as UNIX® or Linux® system errors that correlate to the improper configuration of LDAP that can impact ClearCase authentication and normal usage.
Cause
The following errors correlate to LDAP not being properly configured to allow enough sessions thus causing ClearCase authentication issues.
Typical error messages in ClearCase logs:
=====================================
admin_log:2006-09-27T07:56:46-06 admin_server(22310): Error: file
/vobstorage/vob1.vbs/.identity/group.1003 is not set-id
albd_log:2006-09-25T10:55:40-06 albd_server(6054): Error: Operation "bind" failed: Cannot assign requested address.
albd_log:2006-09-25T10:55:40-06 albd_server(6054): Error: bind: Resource temporarily unavailable
2006-09-25T10:55:38-06 view_server(2523): Warning: Unable to open vob 'cchost1:/vobstorage/vob1.vbs': timed out trying to communicate with ClearCase remote server
2006-09-25T10:55:38-06 view_server(2523): Error: Connect failed.
2006-09-25T10:55:38-06 view_server(2523): Error: vobrpc_server: RPC: Success
2006-09-25T10:55:38-06 view_server(2523): Error: Unexpected error in VOB "cchost1:/vobstorage/vob1.vbs" op vob_ob_register_replica (c63781cf.a0a811d9.8d97.00:01:80:bd:17:8f):timed out trying to communicate with ClearCase remote server
See vobrpc_server_log on host cchost1
Typical error messages in system messages logs:
===========================================
Sep 25 12:02:13 cchost1 see view_log on host cchost1 for more info
Sep 25 12:02:13 cchost1 mvfs: [ID 656060 kern.notice] mvfs: ERROR:
view=view1 vob=/vobs/vob1 - Communications timeout in ClearCase server
Sep 25 12:02:13 cchost1 see view_log on host cchost1 for more info
Sep 25 12:02:13 cchost1 netstat[20071]: [ID 293258 user.error]
libsldap: Status: 91 Mesg: openConnection: simple bind failed - Can't connect to the LDAP server
Sep 25 12:02:15 cchost1 netstat[20071]: [ID 293258 user.error]
libsldap: Status: 7 Mesg: Session error no available conn.
Sep 25 12:02:15 cchost1 automountd[3806]: [ID 293258 daemon.error]
libsldap: Status: 91 Mesg: openConnection: simple bind failed - Can't connect to the LDAP server
Sep 25 12:02:15 cchost1 automountd[3806]: [ID 293258 daemon.error]
libsldap: Status: 7 Mesg: Session error no available conn.
Resolving The Problem
Correct the LDAP server settings to allow sufficient sessions.
Consult your LDAP Administrator or review the documentation to configure LDAP for the required steps to correct the problem.
Related Information
[{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Operating System Configurations","Platform":[{"code":"PF027","label":"Solaris"}],"Version":"2003.06.00;7.0","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}},{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"ALBD","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}},{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"MVFS","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]
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Document Information
Modified date:
16 June 2018
UID
swg21247356