IBM Support

RTNCD=14 FDBK2=13 received after CLSDST RPL for Telnet session

Troubleshooting


Problem

A CLSDST RPL issued from the LOSTERM exit of a PLU application in session with a TN3270 LU fails with RTNCD=14 FDBK2=13 ( 1413 invalid CID ).

Cause

Depending on system configuration, the z/OS Telnet server may issue a TERMSESS RPL followed by CLOSE ACB macroinstruction when terminating a session with a target PLU application. The CLOSE ACB is issued to close the ACB of the LU (VTAM SLU APPL) assigned to the associated TN3270 connection. The CLOSE ACB is issued following completion of the TERMSESS RPL, however, it may be processed before the PLU application has had a chance to issue a CLSDST RPL from its LOSTERM exit. In addition, the NSEXIT of the PLU may also be driven in conjunction with the LOSTERM exit. If the CLOSE ACB terminates the session, the PLU issued CLSDST RPL will fail with a RTNCD=14 FDBK2=13 ( invalid CID ).

Resolving The Problem

This is not an error. It simply indicates that VTAM has already terminated the session due to the CLOSE ACB. Some PLU applications may treat the RTNCD=14 FDBK2=13 as an error and issue messages.

PLU applications should not necessarily deem a RTNCD=14 FDBK2=13 to a CLSDST RPL as an error. The CID for the TN3270 session can be valid when the LOSTERM exit is entered, however, invalid by time the CLSDST is issued. Alternatively, the systems operator should not necessarily consider these messages as an indication that a problem is present.

[{"Product":{"code":"SSSN3L","label":"z\/OS Communications Server"},"Business Unit":{"code":"BU054","label":"Systems w\/TPS"},"Component":"All","Platform":[{"code":"PF035","label":"z\/OS"}],"Version":"1.7;1.8;1.9;1.10;1.11;1.12;1.13;2.1;2.2;2.3","Edition":"","Line of Business":{"code":"LOB35","label":"Mainframe SW"}}]

Document Information

Modified date:
22 June 2018

UID

swg21245363