IBM Support

Error: "Illegal circular USE: DocExpProcessing" when opening folder or mail file

Technote (FAQ)


Question

Using Lotus Notes, when opening a mail file or switching to a view or folder, you are receive the following error multiple times:


    "Error: 'Illegal circular USE: DocExpProcessing'"

The error may occur at other unexpected times but typically occurs when switching to a private view or folder.

Cause

"DocExpProcessing" is a script library in the stock mail template and IBM Mail Template. The design element is still present in the out-of-box mail9.ntf, and should remain in tact, for backward compatibility.

This situation occurs because the private view(s) and or folder(s) still have their design based on the Notes/Lotus Domino mail template but the mail file itself has had its design reverted back to a previous mail template OR there are some customized and protected design elements that engage the DocExpProcessing script library.

NOTE: The Notes/Domino 6.x mail template design does not contain the DocExpProcessing Script Library.

The private folders and views created while using the 7.x or above design cannot locate the library and this is why the error occurs.

This occurs in the following sequence:

1. The mail file design is based on a Notes/Domino 7.x or above mail template design.

2. The user created views and or folders.

3. The mail file design was reverted to an earlier (Notes/Domino 6.x) mail template using Design Replace or a Convert method which did not convert the private folders.


Answer

For private folders:

Use the "Upgrade Folder Design" agent to set the private folders to the Inbox design:

  • From the mail file, choose Action --> Upgrade Folder Design. You can then select either Automatic or Manual operation. If you select Manual, you must check the folders whose design you want to reset to the design of the Inbox. You must close and reopen the database since the design of the folders cache until you do so.

For private views:
The "Upgrade Folder Design" action doesn't work for views.
  • You must either manually copy the actions from another view/folder or use a custom agent with the following function: @UpdateViewDesign("viewname" ; "($Inbox)")
Additional Workaround:
If upgrading the folder design does not resolve the issue, the user may have a custom and protected design element, in the design of the mail file. To verify, use the "Prohibit Design Element Tool" in the "All-in-One" Admin tool database. The instructions to use this file and the specific tool are in IBM Technote # 1459332 All-in-one Admin Tool for agent-based troubleshooting & problem solving

If you prefer to review the design of the mail file directly and resolve it there:
  • Open the mail file in the Designer Client
  • Navigate to the Folders list, and double-click the word "Folders" in the navigation pane, and this will display the complete list of folders in the right hand frame.
  • Sort the "No refresh" column, which is directly right of the "Last Modified By" column, in the right-hand frame (list of all the folders). All users' Personal folders should have a checkmark for "no Refresh" - otherwise they would get overwritten when the design task runs. However, the ($Inbox) and other folders that ship with the mail template should not have the "no Refresh" option checked.
  • Repeat this exercise for the list of Views as well.

To manually uncheck this option for the relevant design element:
  • Highlight the design element in the right-hand column
  • At the bottom of the screen, you should see another frame. Click on "Properties"
  • Go to the Design tab, and uncheck the option for "Prohibit Design Refresh/Replace to modify"
  • Repeat this exercise for all out-of-box design elements that have this option checked
  • IMPORTANT NOTE: Do not uncheck this "Prohibit Design Refresh/Replace to modify" option for any user Personal views and folders --shared or private. If you remove this option in shared or private personal folders, the folders will get removed the next time that the design task runs on it.




Note: If the solutions described above do not resolve the issue, please open a service request with IBM Support for further assistance.

Related information

All-in-one Admin Tool for agent-based troubleshooting &
Error: "Illegal circular use: ..." when working within

Cross reference information
Segment Product Component Platform Version Edition
Messaging Applications IBM Domino Not Applicable AIX, i5/OS, Linux, Solaris, Windows, z/OS 7.0, 6.5, 6.0 All Editions

Document information

More support for: IBM Notes
Mail

Software version: 6.0, 6.5, 7.0, 8.0

Operating system(s): OS X, Windows

Software edition: All Editions

Reference #: 1243687

Modified date: 05 January 2009


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