IBM Support

Unable to import tool shortcuts in ClearCase Explorer

Technote (troubleshooting)


Problem(Abstract)

This technote identifies a defect that was introduced as of IBM® Rational® ClearCase® Service Release 5 which impacts the ability of the ClearCase Explorer GUI to import tool shortcuts.

Symptom

Attempts to import tool shortcuts into ClearCase Explorer fails with ClearCase 2003.06.15 (SR 5) or later.

The problem only occurs when the user chooses the Remove Page option to delete the page, and then performs import steps.

Problem Scenario:

  1. In ClearCase Explorer, create a new page on the Toolbox tab:
  • Right-click in Toolbox and select Add Page:



  • Provide a page name:



  • Verify Page Creation (in 7.0 use drop-down menu):





    1. Add a tool shortcut button to the Toolbox.

    For demo purposes a button to start notepad.exe is added.
    • Select new page, right-click page and select Add Tool Shortcut:



    • Provide a name (Label) for the shortcut and a description, if needed:



    • Click the Program tab to select the path to the executable:



    • Verify short on the page:



    2. Export the settings to an XML file.
    • Right-click the page and select Export:



    • Select the tool shortcut to export and browse for a path to store the XML file.



    3. Import the tool shortcut.

    Note: You will need to remove the page in ClearCase Explorer first.
    • Right click on the page and select Remove Page.



    • To import the tool short, right-click any page in the toolbox and select Options:



    • Click the Import tool shortcuts at each startup button and provide the path to the XML file and click OK.




The result is that the previously exported shortcut page does not appear in the Toolbox tab.



The expected result is:

Cause

Defect APAR PK45828 has been submitted to investigate this problem.


Resolving the problem


The decision was made by Product Management to exclude the resolution of this defect from future upgrades and releases due to the significant architectural changes required to implement the solution.

WORKAROUNDS:

  • Avoid performing a Remove page operation

  • Remove all user modifications by using the Reset to defaults option in the shortcut page options.

    This can be shown using the following process:
    1. In ClearCase explorer, right-click Toolbox tab and create a new page, through Add Page

    2. Right-click the new page and add a new tool shortcut through Add Tool Shortcut

    3. Right-click the new page and choose Export

    4. In the Export Tool Shortcuts dialog, check the new shortcut, select a file location and choose OK

    5. Rightclick the new page and choose Options

    6. Choose Reset to Defaults to remove the new page added

    7. Restart ClearCase Explorer

    8. Right-click ToolBox tab and choose "Options"

    9. In the Importing group box choose "Import tool shortcuts at each startup" and select the location of exported xml file in Step d

    10. The new page along with the shortcut is now added

Cross reference information
Segment Product Component Platform Version Edition
Software Development Rational ClearCase GUI: ClearCase Explorer

Document information

More support for: Rational ClearCase
GUI: ClearCase Explorer

Software version: 7.0, 7.0.0.1, 7.0.1, 2003.06.15, 2003.06.16

Operating system(s): Windows

Reference #: 1243654

Modified date: 20 November 2007