IBM Support

Select View Name dialogue opens when trying to access change set versions

Troubleshooting


Problem

This technote details why the Select View Name GUI dialogue and the command line error, cleartool: Error: Cannot get view info for current view: not a ClearCase object, will appear when accessing the change set versions of an IBM® Rational® ClearCase® UCM activity.

Symptom

GUI

From Project Explorer > select a stream > right-click an activity in the right-hand pane > choose Properties > select the Change Set tab, and the following appears:

------------------------------------------------
Select View Name
------------------------------------------------
The name of the view used to  [OK]
generate the names of versions in the [CANCEL]
change set.
[                                               ]
------------------------------------------------


When using ClearQuest, this select view name can also appear when you click on the UCM tab of a ClearQuest record with change set information. The message occurs for the same reason - no view is running on the computer (or ClearCase as a whole is not running). This is in ClearQuest client for Windows. This error message does not appear automatically in ClearQuest Eclipse. Instead, when you click on the UCM tab, you don't receive the error message. You will see a button that says 'View Change Sets'. Only if you click that button will the 'Select View Name' dialog pop-up.

The GUI functionality is user id driven; hence, the returned results are based on the logged in user account only.

This dialogue indicates that the logged in user does not own the activity and or that there is no view started on the local host.

By clicking OK or Cancel without entering a valid view name, the version extended pathname will be listed as <Unavailable> with the version number to the right:




CLI

From command line, an error is reported in the output:


C:\>cleartool lsactivity -l foo@\pvob1
activity "foo"
 2006-07-19T12:00:57-04 by admin.ccusers@IBM-D15F3483123
  owner: IBM-D15F3483123\admin
  group: IBM-D15F3483123\ccusers
  stream: admin_proj1_dev@\pvob1
  current view: admin_proj1_dev_vu
  title: foo
  change set versions:
cleartool: Error: Cannot get view info for current view: not a ClearCase object.
cleartool: Error: Cannot determine view context.


The command line works in similar fashion as the GUI, in that it can use any available view to display the details of an activity. However, when there is no view context, it does not prompt for a view and just returns the above error.

Cause


Listing or displaying change set versions require a view context.

The change set information for element versions exist solely in the VOB, and ClearCase is unable to resolve this information when not set into a view.

Review the ClearCase Command Reference Guide on the topic of lsactivity (cleartool man lsactivity) for more information.

Resolving The Problem


Options for displaying Change Set Versions

To display the change set versions in the activity:

  1. From GUI, you can enter a valid view name in the Select View Name dialogue, even if:
    • You do not own the activity or the view,
    • The view is not attached to the stream that the activity is associated with, and
    • The view is not a UCM view

      OR

  2. From command line, you must be set into a view context when you execute:
    • cleartool lsactivity -l activity:<act name>@\PVOB, or
    • cleartool describe -l activity:<act name>@\PVOB

GUI

The GUI behavior is determined by the activity and view ownership.

Meaning, if you own the activity that you are opening the Properties for and own a view that is running on the local host, then the GUI will pre-populate the Select View Name pop-up with a view. Thus, you do not get prompted to enter a view name.

Note: When using a snapshot view, the view root must be accessible from the host if it is not local to that workstation.



The default functionality checks for and uses a view (owned by the logged in user) that is attached to the stream first, if one does not exist, then it will look for another view that is running and use that.

The natural way of selecting a view by ClearCase is:
  1. an active dynamic view attached to the stream of the activity
  2. a current working directory view (pwv) or started dynamic view
  3. any active dynamic view
  4. a snapshot view known to user attached to the stream of the activity
  5. a current working directory view
  6. snapshot view known to user

So when case 1 above does not select a view, the system takes case 2 or 3 and does not try case 4 which would succeed. This causes ClearCase to open an incorrect view.

A view context will allow the change set versions to get displayed correctly on the Change Set tab of the Properties window:


CLI

From command line, change into a view context when listing the details of a UCM activity:
    M:\admin_proj1_dev_vu>ct lsactivity -l foo@\pvob1
    activity "foo"
     2006-07-19T12:00:57-04 by admin.ccusers@IBM-D15F3483123
      owner: IBM-D15F3483123\adminn
      group: IBM-D15F3483123\ccusers
      stream: admin_proj1_dev@\pvob1
      current view: admin_proj1_dev_vu
      title: foo
      change set versions:
        M:\admin_proj1_dev\multivob\comp1\dir1@@\main\admin_proj1_dev2\2
        M:\admin_proj1_dev\multivob\comp1\dir1\beta.txt@@\main\admin_proj1_dev2\1
        M:\admin_proj1_dev\multivob\comp1@@\main\admin_proj1_dev2\2
        M:\admin_proj1_dev\multivob\comp1\dir1@@\main\admin_proj1_dev2\1
        M:\admin_proj1_dev\multivob\comp1\test1.txt@@\main\admin_proj1_dev2\3
        M:\admin_proj1_dev\multivob\comp1\test1.txt@@\main\admin_proj1_dev2\2

Review IBM Rational ClearCase Developing Software manual on the topic of Viewing a change set of an activity for more information.


If this message occurs in the ClearQuest Client for Windows, the following workaround can be used:

WORKAROUND
The workaround is to use ClearQuest Eclipse instead of ClearQuest Client for Windows. In ClearQuest Client for Windows, the message appears automatically. In ClearQuest Eclipse, the message only appears if you click the View Change Set button on the UCM tab. So, in ClearQuest Eclipse, the message won't appear if you just happen to click on the UCM tab, unlike in ClearQuest for Windows Client.



Feature Enhancement

Change request, (RFE) RATLC00693203, was opened concerning this functionality. It is requesting that the Select View Name pop-up not be required, or if the functionality cannot be changed, then it should provide a drop-down list of views to select from and or provide a Create View option.

The decision was made by Product Management to exclude the resolution of this feature from future upgrades and releases of ClearCase UCM due to the significant architectural changes required to implement the solution.

[{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"UCM: Activity","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"7.0.1;7.0;2003.06.16;2003.06.00","Edition":"","Line of Business":{"code":"LOB36","label":"IBM Automation"}},{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"UCM: Activity","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB36","label":"IBM Automation"}},{"Product":{"code":"SSSH5A","label":"Rational ClearQuest"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Client - Eclipse RCP","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}},{"Product":{"code":"SSSH5A","label":"Rational ClearQuest"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Client - Eclipse Plug-in","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}},{"Product":{"code":"SSSH5A","label":"Rational ClearQuest"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Client - Native Windows","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21242846