Skip to main content

Windows Security Alert, Windows has blocked Java Launcher


Technote (troubleshooting)


Problem(Abstract)

When bringing up the WebSphere® Developer for zSeries® V6.0.1 product, a Windows Security Alert popup window appears stating that Windows has blocked Java Launcher, Your computer administrator can unblock this program for you.

Cause

Windows XP SP2, Security Alert feature

Resolving the problem

Options:

- Deploy Group Policy to the XP clients to disable the firewall.
- Deploy a scipt to all clients using the commands to configure the firewall rules.
(netsh firewall add allowedprogram "C:\Program Files\IBM\WebSphere Studio\runtimes\base_v5\java\bin\javaw.exe" "Java launcher"; the path directory may be different based on installation/Product/Version.)
- Configure local policy with port exceptions or program exceptions.

Troubleshooting Windows Firewall settings in Windows XP Service Pack 2:
http://support.microsoft.com/kb/875357/
Deploying Windows Firewall Settings for Microsoft Windows XP with Service Pack 2:
http://www.microsoft.com/downloads/details.aspx?familyid=4454e0e1-61fa-447a-bdcd-499f73a637d1&displaylang=en

Related information

Troubleshooting Windows Firewall Settings in Windows XP
Deploying Windows Firewall Settings for Microsoft Win X

Rate this page:

(0 users)Average rating

Copyright and trademark information

IBM, the IBM logo and ibm.com are trademarks of International Business Machines Corp., registered in many jurisdictions worldwide. Other product and service names might be trademarks of IBM or other companies. A current list of IBM trademarks is available on the Web at "Copyright and trademark information" at www.ibm.com/legal/copytrade.shtml.

Rate this page:


(0 users)Average rating

Add comments

Document information

WebSphere Developer for zSeries

General Information


Software version:
6.0, 6.0.1


Operating system(s):
Windows


Software edition:
All Editions


Reference #:
1240744


Modified date:
2011-03-15

Translate my page

Content navigation