IBM Support

Cannot bind an admin_server handle on Windows

Troubleshooting


Problem

This technote provides a list of the common errors and application conflicts associated with the error, cleartool: Error: Cannot bind an admin_server handle on "host1": error detected by ClearCase subsystem., when attempting to create and or start an IBM Rational ClearCase view or VOB on Microsoft Windows.

Symptom

The following error is reported when attempting to create a view or VOB or when trying to start a view.

cleartool: Error: Cannot bind an admin_server handle on "host1": error detected by ClearCase subsystem.

Note: If you are attempting to create a VOB or view on a NAS filer and receive the Cannot bind an admin_server handle error, review technote 1124253 for more details.

Cause


The error is caused by any one of a number of different programs conflicting with Rational ClearCase on the local machine.

IMPORTANT: The program could be legitimate and purposely installed on a system or it could also be spyware that is running unknowingly on a system.

If the program is legitimate, please contact the vendor for information about moving it down the protocol stack.

In either case, these problematic programs can be running on top of the TCP/IP stack on a Windows system which prevents ClearCase from functioning properly, such as the system's performance being impacted by freezing or hanging when accessing objects in a view.



Examples:

Attempts to create a dynamic view results in the following errors:

  • During View creation using the View Creation Wizard:

    Error creating view '<view tag>'
    Problem starting admin_server for host <host name>
    See albd_log or admin_log on host <host name>
    Cannot bind an admin_server handle on "<host name>": error detected by ClearCase subsystem
    Unable to create view "\\<host name> \<share>\<view tag>.vws"



  • During VOB creation using the VOB Creation Wizard:

    Error creating VOB
    VOB Creation Wizard Error: Cannot bind an admin_server handle on "<host name>":
    timed out trying to communicate with ClearCase remote server.
    VOB Creation Wizard error: Problem starting vob_server for vob <host name>:drive:\<share>\<VOB tag>.vbs
    VOB Creation Wizard error: See albd or vob error logs on host <host name>
    VOB Creation Wizard Error: Unable to create versioned object base
    "\\<host name>\<share>\<VOB tag>.vbs".


  • Attempts to run cleartool getlog returns the following errors:

    >cleartool getlog -all -full
    admin_contact_call_V1: RPC: Unable to receive; errno = [WINSOCK] Connection reset by peer


    >cleartool getlog -all -full
    cleartool: Error: Problem starting admin_server for host <host name>
    cleartool: Error: See albd_log or admin_log on host <host name>

    adm_log_list_if_V1: RPC: Unable to receive; errno = [WINSOCK] Connection reset by peer    



  • Additional errors in the ClearCase logs (as well as the Event Viewer logs) related to this problem:

    admin log:

    admin_contact_call_V1: RPC: Unable to receive; errno = [WINSOCK] Connection reset by peer

    albd log:

    Albd(496): Error: Server admin_server.exe (pid=3144) on "" died on
    startup; marking it as "down".


    cccredmgr log:

    cccredmgr(556): Warning: OpenProcessToken failed: Error 5: No additional description available for this system error.

    Event Viewer - System Log:

    Application popup: admin_server.exe -
    Application Error : The exception unknown software exception (0xccccdead) occurred in the application at location 0x7c81eb33.

    view log:
    view_contact call failed: RPC: Unable to receive; errno = "WINSOCK¨
    Connection reset by peer

    Resolving The Problem

    In order to check to see if you have a program that is conflicting with ClearCase follow the instructions below:

    1. Click on Start > Run type winmsd and hit the Enter key.

    Note: A window will pop up that says System Information.

    2. In the left hand pane of the window, expand the Components item.

    3. Then expand Network and click on Protocol.

    4. In the right hand pane of the window you will see an Item and a Value column.

    Note: The first entry should be MSAFD Tcpip [TCP/IP] and the second should be MSAFD Tcpip [UDP/IP].


  • If the first item does not list MSAFD Tcpip [TCP/IP] and lists something else, then spyware is more than likely to be running on the system.

    Example:

    Item Value
    Name OSMIM --> MSAFD Tcpip [TCP/IP]
    ConnectionlessService False
    GuaranteesDelivery True
    GuaranteesSequencing True
    MaximumAddressSize 16 bytes
    MaximumMessageSize 0 bytes
    MessageOriented False
    MinimumAddressSize 16 bytes
    PseudoStreamOriented False
    SupportsBroadcasting False
    SupportsConnectData False
    SupportsDisconnectData False
    SupportsEncryption False
    SupportsExpeditedData True
    SupportsGracefulClosing True
    SupportsGuaranteedBandwidth False
    SupportsMulticasting False


    Note: This is an example of the MarketScore spyware application signature.

  • You will need to run a spyware removal tool to completely remove this program from the system.

  • If the first item lists something like SlipStream over MSAFD Tcpip [TCP/IP] then a conflicting program is installed on the ClearCase host.
  • Remove this program by using the Add or Remove Programs in the Windows Control Panel.




    Known Applications that Conflict with ClearCase (click to expand)
    • Adware
      • 180 Search Assistant
      • ShopAtHomeSelect
      • Golden Retriever

    • Web browser accelerators
      • SlipStream
      • Webcelerator

    • Internet monitoring and security
      • webHancer Customer Companion
      • HTTPLook
      • Embassy® Trust Suite

    • Host Intrusion Prevention
      • McAfee Host Intrusion Prevention for servers

    • VPN client software
      • Shiva
      • Aventail Connect
      • Whale Communications Client Components

    • Firewall programs
      • Microsoft Firewall Client
      • McAfee Firewall (see technote 1154548)
      • Black Ice
      • Proventia Desktop
      • Zone Labs (shutting down Zone Labs is sufficient - no need to remove).
      • Comodo Firewall/Anti-Virus

    • Anti-Virus programs
      • NOD32
      • F-Secure

    • Spyware
      • MarketScore
      • SAHAgent (ShopAtHomeSelect Agent)
      • Inetadpt.dll is spyware made by Virtumundo, Inc.

    • Proxy software
      • Neoteris (Secure Application Manager)
      • Permeo e-Border Premium Agent

    • Connection software
      • Sprint PCS Connection Manager
      • Venturi Client for Verizon Wireless
      • T-Mobile PC-Card
      • AT&T Communications Manager
      • Software for the Vodafone UMTS modem

        Note:
        This software is compressing all network traffic, which interferes with ClearCase operations. Contact Vodafone support for a version of the software which does not compress the network traffic.

    • Port monitors
      • DiamondCS Port Explorer
      • TCP Spy

    • Data Replication Software
      • WANSync by XOsoft Corp

    • Virtual Networks
      • Microsoft Loopback Adapter

        Note: The Microsoft loopback adapter is used to create a virtual networking environment when a real network is not accessible to the machine. This is described in a Rational ClearCase stand alone configuration as detailed in technote 1149308.

        The loopback adapter, combined with the client - server nature of Rational ClearCase is causing the machine to fail to resolve it's own name in background ClearCase processes.

        The only solution is to remove the Microsoft loopback adapter. Refer to technote 1188184 for directions.

    [{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Application Conflicts","Platform":[{"code":"PF033","label":"Windows"}],"Version":"7.0.1;7.0;2003.06.00","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}},{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Application Conflicts","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

    Document Information

    Modified date:
    16 June 2018

    UID

    swg21240722