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Cannot start services: cccredmgr

Troubleshooting


Problem

This technote details why the error "Cannot start services: cccredmgr" can occur when installing IBM® Rational® ClearCase® 2003.06.15 (Service Release 5) on Microsoft® Windows® Server 2003.

Cause

Attempts to install Rational ClearCase 2003.06.15 on Windows Server 2003 (Standard Edition), during the setup procedure results in the following error:


    "cannot start services: cccredsmgr"

Note: This error continues to occur on subsequent install attempts.

The rational_install.log, on the host where the install failed, contains this message:

    "StartServices: Service: Rational Cred Manager Info 1920.Service Rational Cred Manager (cccredmgr) failed to start.  Verify that you have sufficient privileges to start system services.
    Action ended 10:10:07: InstallFinalize. Return value 3.
    Action 10:10:07: Rollback. Rolling back action:
    Rollback: Starting services
    Rollback: Registering Dlls...

Note: The location of the log file, by default, is: C:\Documents and Settings\<username>\Local Settings\Temp

This error happens when the account used to install Rational ClearCase does not have full access on the local host or a conflicting application is preventing the process from completing.

Resolving The Problem

The ClearCase Credentials Manager (cccredmgr.exe) is the credentials mapping server, which runs on any ClearCase host that is configured to support local VOBs and views:




TROUBLESHOOTING:

Note: It may be necessary to uninstall or cleanup behind the failed install attempt before trying to run it again; refer to technote 1179647 for directions.

  1. Verify the account used to install Rational Clearcase has the correct level of permissions on the local host; such as Local Administrator rights, which is able to start the system services.

  2. Make sure all of the following are turned off and or disabled during the installation:
    • Any unnecessary Programs
    • Any Anti-Virus software, refer to technote 1149511
    • Any firewall software; refer to the ClearCase Knowledge Center
    • Any VPN software
    • Application Monitoring software (such as BlackICE, Spybot, or McAfee®)
      Note: These applications may need to remain disabled after the install to use ClearCase successfully on this host.

  3. If the above do not resolve the problem, then copy the install files (from the release area) to a local disk and run the installation from there.

  4. If the problem persist, collect the ClearCase logs from the host (technote 1131335), then submit an ESR as detailed below.

[{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Installation","Platform":[{"code":"PF033","label":"Windows"}],"Version":"7.0","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}},{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Permissions","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}},{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Credmap Server","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21236662