GSKit V7 and V8 installation directories on the UNIX and Windows platforms

Technote (troubleshooting)


Problem(Abstract)

The WebSphere MQ V7.0.1 Quick Beginnings Guides state the following regarding the IBM Global Security Kit (GSKit) V7 and V8:

"Creating WebSphere MQ file systems

The installation directory for the WebSphere MQ product code is /usr/mqm. Working data is stored in /var/mqm. You cannot change these locations. The GSKit must also be installed into its default location."

However, the documentation does not state the default installation directory for the GSKit utility.

Resolving the problem

+++ MQ 7.1 and 7.5

Starting with MQ 7.1, the installation directory for the GSKit V8 code shipped with MQ is:
MQ_INSTALLATION_PATH/gskit8*

Examples:

Windows: if MQ 7.1 is installed in Windows:
C:\Program Files\IBM\WebSphere MQ_1
Then in 7.1.0.2 there are 2 directories:
gskit8
gskit8.8.0.14.12

UNIX: If MQ 7.5 is installed in Linux in:
/opt/mqm75
Then there is 1 directory:
gskit8



+++ MQ 7.0 and 7.0.1

Below are the default GSKit installation directories for UNIX and Windows platforms in WebSphere MQ 7.0 and 7.0.1:

AIX :

GSKit V7 (file sets gsksa.rte and gskta.rte):
/usr/opt/ibm/gsksa/
/usr/opt/ibm/gskta/

GSKit V8 (file sets gskcrypt32, gskssl32, gskcrypt64 and gskssl64):
/usr/opt/ibm/gsk8/
/usr/opt/ibm/gsk8_64/

Linux :

GSKit V7 (package gsk7bas and, where applicable, gsk7bas64):
/usr/local/ibm/gsk7/
/usr/local/ibm/gsk7_64/ (64-bit platforms only)

GSKit V8 (packages gskcrypt32 and gskssl32. Also, where applicable, gskcrypt64 and gskssl64):
/usr/local/ibm/gsk8/
/usr/local/ibm/gsk8_64/ (64-bit platforms only)

Solaris and HP-UX:

GSKit V7 (packages gsk7bas and gsk7bas64):
/opt/ibm/gsk7
/opt/ibm/gsk7_64

GSKit V8 (packages gskcrypt32, gskssl32, gskcrypt64 and gskssl64):
/opt/ibm/gsk8
/opt/ibm/gsk8_64

Windows:

GSKit V7:
C:\Program Files\IBM\gsk7

GSKit V8:
C:\Program Files\IBM\gsk8


Product Alias/Synonym

WMQ MQ

Rate this page:

(0 users)Average rating

Document information


More support for:

WebSphere MQ
Install / Migration

Software version:

6.0, 7.0, 7.0.1, 7.1, 7.5

Operating system(s):

AIX, HP-UX, Linux, Solaris, Windows

Reference #:

1235545

Modified date:

2013-04-15

Translate my page

Machine Translation

Content navigation