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WMSG0902E: The WebSphere MQ JMS Binders have been disabled as either the WebSphere MQ Client has not been installed, or the MQ_INSTALL_ROOT variable has not been set.

Troubleshooting


Problem

When using the WebSphere MQ JMS Provider in WebSphere Application Server V5 or V6, the following error may appear in the SystemOut.log during the startup of an application server: [] WMSG0902E: The WebSphere MQ JMS Binders have been disabled as either the WebSphere MQ Client has not been installed, or the MQ_INSTALL_ROOT variable has not been set. [] When this occurs, an application will receive a NameNotFoundException every time that it tries to do a JNDI lookup of a JMS connection factory or destination that is configured under the WebSphere MQ JMS Provider.

Cause

The problem occurs when WebSphere Application Server has not been properly configured to locate the WebSphere MQ Client or the WebSphere MQ Server on the system.

Resolving The Problem

To resolve the problem, follow these steps:

  1. Ensure that either the WebSphere MQ Client (if you're connecting to a remote MQ server) or the WebSphere MQ Server is installed on the same system as WebSphere Application Server.

  2. Configure the MQ_INSTALL_ROOT and MQJMS_LIB_ROOT environment variables to point to the directory where the MQ client or server is installed on your system:
    • In the Administrative Console, expand Environment, and select Manage WebSphere Variables (for V5) or WebSphere Variables (for V6).
    • Provide a value for the MQ_INSTALL_ROOT variable. The value should be the directory where the WebSphere MQ client or server is installed on your system. The default directory for your operating system would be:
    • Operating System
      Default MQ installation directory
      Windows®C:\Program Files\IBM\WebSphere MQ
      AIX®/usr/mqm
      Linux®/opt/mqm
      Sun Solaris/opt/mqm
      HP-UX/opt/mqm
    • Ensure that the MQJMS_LIB_ROOT variable is set to its default value, which is:
      ${MQ_INSTALL_ROOT}/java/lib.

  3. After making these changes, restart your application server. The problem should now be resolved.

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Document Information

Modified date:
15 June 2018

UID

swg21231315