IBM Support

DIA8511C A locked file was encountered

Question & Answer


Question

During normal DB2® operation on Windows® the following error occurs: DIA8511C A locked file was encountered occurs in the db2diag.log file, followed by the error: ZRC=0x870F000E Typical format of the error as seen in the db2diag.log is : 2005-08-31-09.40.57.589000-240 I4755451H365 LEVEL: Severe PID : 123 TID : 4567 PROC : db2syscs.exe INSTANCE: DB2 NODE : 000 FUNCTION: DB2 UDB, data protection, sqlpgwlp, probe:1350 RETCODE : ZRC=0x870F000E=-2029060082=SQLO_LOCK "ERROR_LOCK_VIOLATION (DOS)" DIA8511C A locked file was encountered. Depending on which file DB2 accesses, DB2 may continue to run or this problem may cause further errors (typically failure to access log files) which are reported in the db2diag.log.

Cause

A possible cause for this error is the presence of a third-party program such as an external backup or restore program, or a virus checker program has a lock on a DB2 data file. The error code 0x870F000E equates to ERROR_LOCK_VIOLATION (DOS).

Answer

Review the settings for third-party programs and ensure that they do not place a Windows file lock on the files being accessed by DB2. If you are using a third-party program to back up DB2, we recommend you use the DB2 BACKUP utility instead. Alternatively, ensure DB2 is shut down or in quiesced state before running the third-party program.

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Document Information

Modified date:
16 June 2018

UID

swg21225179