IBM Support

MustGather: Host On-Demand Service Manager on z/OS fails to start

Question & Answer


Question

What information should you collect to troubleshoot IBM Rational Host On-Demand Service Manager task issues using JCL?

Cause

Several things can cause the Service Manager to fail to start on z/OS:

  • PATH, and LIBPATH statements are incorrect for the Java path in /etc/profile
  • The filesystem for Host On-Demand is not mounted correctly to the system
  • Permissions are not set to 755 for each directory along the install path, the default is /usr/lpp/HOD/hostondemand.
  • The userid associated with the HOMSERVR started task does not have an OMVS segment defined.
  • If you are using multiple TCP/IP stacks, the service manager is not bound to the correct stack.
  • Java™ is at an un-supported level.
  • The Service Manager is already started.

Answer

Refer to the Hints and Tips section of the Program Directory for more information.

If you checked the above and are unable to determine the reason for the failure, turn on /d3 tracing and collect the following:

  • STDOUT and STDERR files
  • /usr/lpp/HOD/hostondemand/private/ServiceManager.sh
  • /etc/profile
  • /usr/lpp/HOD/hostondemand/private/NCoDServices.RAS.txt
  1. Turn on Service Manager tracing by uncommenting the line containing /d3 in ServiceManager.sh found in the private directory (/usr/lpp/HOD/hostondemand/private is the default location)

  2. Start the Service Manager and collect the above documents

To determine where the STDOUT and STDERR files are, check the HOMSERVR JCL procedure, It should have the following statements:
//STDOUT DD PATH='/tmp/homservr-stdout',
// PATHOPTS=(OWRONLY,OCREAT,OTRUNC),
// PATHMODE=SIRWXU
//STDERR DD PATH='/tmp/homservr-stderr',
// PATHOPTS=(OWRONLY,OCREAT,OTRUNC),
// PATHMODE=SIRWXU

STDERR should give more information as to why it fails.

If you have more than one TCP/IP stack, you can bind Host On-Demand to a specific stack via ENVAR PARM='sh /usr/lpp/HOD/hostondemand/lib/ServiceManager.sh'
'ENVAR("_BPXK_SETIBMOPT_TRANSPORT=xxxxxxxx")'
where xxxxxxxx is the TCPIP started task name.


What to do Next?
Once the MustGather information is collected, submit the diagnostic information to IBM® support. See the Submitting Diagnostic Information to IBM Technical Support for Problem Determination document for specific information.

For a listing of all technotes, downloads, and educational materials specific to Rational Host On-Demand, see the Host On-Demand support portal.

[{"Product":{"code":"SSS9FA","label":"IBM Host On-Demand"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Documentation","Platform":[{"code":"PF035","label":"z\/OS"}],"Version":"11.0","Edition":"","Line of Business":{"code":"LOB35","label":"Mainframe SW"}}]

Historical Number

Document Information

Modified date:
02 August 2018

UID

swg21220236