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Cannot get view info for working directory view

Technote (troubleshooting)


Problem(Abstract)

This technote explains why starting IBM® Rational® ClearCase® on UNIX® or Linux® fails with the error Cannot get view info for working directory view error detected along with the steps to resolve the problem.

Symptom

When running the clearcase or atria_start script, the following error is received:

Cannot get view info for working directory view error detected."
ERROR: This routine can't be executed in a view context.
Stopping prematurely due to encountered error.


This error may also appear during a ClearCase upgrade:

Continue installation?(yes, no, quit)[yes]:
***************************************************************************
>> Shutdown running ClearCase Product Family software
***************************************************************************
         Shutting down running ClearCase Product Family software.
         This will interfere with current users of the installed software.
         
         Running:/opt/rational/clearcase/etc/clearcase stop
         The following command was executed, but returned an error:
 
             /opt/rational/clearcase/etc/clearcase stop
 
          The following is the command output:
          ----
          cleartool: Error: Cannot get view info for working directory view: Invalid argument.
ERROR:  This routine can't be executed in a view context.
Stopping prematurely due to encountered error.
 
          ----
          End of command output.
 
ERROR:  
The "/opt/rational/clearcase/etc/clearcase stop " script reported an error while
      shutting down running ClearCase Product Family software.  The
      installation can not continue until the active ClearCase software
      is terminated. Please review the preceding command output for the
      encountered problem(s).  After these problems have been addressed,
      please retry the software install or deinstall.
 
 
Stopping prematurely due to encountered errors.
FINAL:agsosg00  Errors:1        Warnings:0



Cause

The cause of this problem relates to a corrupted .specdev file in /view.


Resolving the problem

Solution 1

Remove the .specdev file and restart Rational ClearCase:

  1. cd /view
  2. Remove the .specdev file

    rm -rf .specdev

    Note: You may also find a stale subdirectory under /view that needs to be removed.
  3. Restart ClearCase

    %CCHOME%/etc/atria_start stop
    %CCHOME%/etc/atria_start start

Solution 2

If the first solution does not work, attempt to recreate the .specdev file and restart ClearCase.

Note: Review technote 1135104 for steps on recreating he .specdev file.

Solution 3

If neither solutions work, attempt to uninstall and reinstall ClearCase.

Review the related information section for addition help if required.

Related information

Manually uninstall ClearCase on Solaris
Manually uninstall ClearCase on AIX
Manually uninstall ClearCase on HP-UX
About the .specdev file in /view directory

Cross Reference information
Segment Product Component Platform Version Edition
Software Development Rational ClearCase MVFS

Document information

More support for: Rational ClearCase
View: Dynamic

Software version: 7.0, 7.0.1, 2003.06.00

Operating system(s): AIX, HP-UX, IRIX, Linux, Solaris

Reference #: 1218857

Modified date: 10 October 2008