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Shared memory Realm does not exist error, when logging into ClearQuest

Troubleshooting


Problem

This technote addresses the error "Shared memory Realm does not exist". This can occur when you try to log into IBM® Rational® ClearQuest® on UNIX® platforms.

Symptom

This Oracle error can occur when you try to log into the ClearQuest UNIX client:

Openlink Broker Error: Shared memory Realm does not exist.
OpenLink: [Oracle Server]ORA-01034: Oracle not available. ORA-27101: Shared memory realm does not exist. SVR4 Error: 2: No such file or directory [SQLSTATE:S1000]

Cause

The case of the Oracle SID or HOST values might be incorrect. For example, the HOST or SID values of the connection options are stored all in upper case. The server may be defined with lower case values.

Environment

This problem occurs with ClearQuest environments hosted on Oracle databases. It is observed when using UNIX-based operating systems.

Resolving The Problem

Change the connection options for your ClearQuest databases. They should match the case of values as configured on the Oracle server.

  1. To fix the user database connection options, you will need to login to ClearQuest Designer on Microsoft® Windows® computer.
  2. Select the menu option Database > Update User Database Properties.
  3. This will bring up the Update User Database Properties dialog.
  4. In the dialog, update the SID and/or HOST values so that they have the correct case.
  5. Now update the Schema Repository. On the same computer, open the ClearQuest Maintenance Tool.
  6. Select the menu option Schema Repository > Update.
  7. Correct the connection options in the same manner.



Disclaimer

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Document Information

Modified date:
16 June 2018

UID

swg21216820