IBM Support

SMTP mail is stamped with incorrect time

Troubleshooting


Problem

When mail is received that was sent by SMTP, it is stamped with the incorrect time.

Symptom

email has the wrong time

Cause

When the mail is received using a mail client, it uses the RFC 822 Date header to determine what time to use to indicate the time the mail was received. If there is not a timezone in this header, or if the timezone is incorrect , then the wrong time will be displayed.

Resolving The Problem

The correct timezone must be coded on the RFC 822 Date header. If the header is not present when SMTP pulls the message off the JES spool, SMTP will add the header using the TIMEZONE parameter set in the SMTP configuration file. If it is present, SMTP will not modify the header.

Use the following syntax:

Date: [ day "," ] date hour zone

For example:

Date: Fri, 04 Feb 05 21:48:57 EST
or
Date: Fri, 04 Feb 05 21:48:57 -0500

Refer to RFC 822 for more information on how to specify the Date header.

[{"Product":{"code":"SSSN3L","label":"z\/OS Communications Server"},"Business Unit":{"code":"BU054","label":"Systems w\/TPS"},"Component":"All","Platform":[{"code":"PF035","label":"z\/OS"},{"code":"PF025","label":"Platform Independent"}],"Version":"1.6;1.7;1.8;1.9;1.10;1.11;1.12;1.13;2.1;2.2","Edition":"","Line of Business":{"code":"LOB35","label":"Mainframe SW"}}]

Document Information

Modified date:
15 June 2018

UID

swg21200936