IBM Support

Unable to complete, resume or cancel a deliver after target view is removed

Troubleshooting


Problem

This technote details a deliver error that can occur if the target view becomes unavailable (or removed) while a deliver is still in progress when using IBM Rational ClearCase UCM.

Symptom


Attempts to complete or resume a deliver, result in the following error:

C:\ClearCase_storage\project_snapshot_devint>cleartool deliver -complete
cleartool: Error: Unable to find view by
uuid:4bb6c357.3e794e15.8c29.d4:9e:2f:19:6e:2e, last known at "unknown:unknown".
cleartool: Error: Unable to get view handle.
cleartool: Error: Unable to recreate target view context.
cleartool: Error: Unable to restore operation.
cleartool: Error: Unable to restore from pvar.
cleartool: Error: Unable to deliver stream "project5235_devint".

Cause

The target view that was associated with the deliver when it was started is no longer available, which left the deliver operation in an unresolved state that it cannot process or terminate.

If you need to know more details about the deliver operation that is in-progress, such as who initiated it, then use the command "cleartool deliver -status"

Diagnosing The Problem

To determine which view is unavailable, review the error to see which stream has the issue.

Resolving The Problem



Try to recover the target view

If you are able to determine why the view is no longer available, attempt to resolve the problem with the view and proceed with the deliver.

For example, if the view was mistakenly unregistered or untagged in the region:

  1. Register and or tag the view in the region:
    • cleartool mktag -view -tag <view-tag> <global path to view-storage>
    • cleartool register –view <global path to view-storage>

  2. Attempt to resume the deliver or cancel it:
    • cleartool deliver -resume | cancel



Try using a new target view


If you are not able to resume or cancel the deliver in the original target or source view, then try using a new target or source view. You can reset the deliver operation to use a different view that is attached to the target stream that you are trying to deliver to.

Note: If there is no alternate view already created, then you will need to create a new view first to use this option, cleartool mkview –tag <new-target-view-tag> –stream <target_stream>@\PVOB -stgloc -auto


The syntax to reset the deliver operation is:

  • cleartool deliver -complete -reset -to <new-target-view-tag>
or
  • cleartool deliver -cancel -reset -to <new-target-view-tag>


For more details, refer to the IBM Rational ClearCase Command Reference, under the topic of deliver or run cleartool man deliver (see the information for -reset).


If the above are unsuccessful, contact IBM Rational Client Support

If you are not able to resolve this error and proceed with the deliver, then send the following information into IBM Rational Client Support. We will provide you with a set of utilities and directions to resolve the error.

Note: Create a directory to hold the files with the redirected command output. This will make it easy to zip them up and send the information to support. Review the Exchanging information with IBM Technical Support for details on how to send information to support.



The activity and stream to be specified in the commands below can be identified with the output of the first command, "deliver -status".
The stream is the source steam. ("Deliver operation in progress on stream")
The activity is the integration activity. ("Using integration activity")
  1. cleartool deliver -status -long > deliver_status.txt
  2. cleartool describe -l activity:activity_name@\PVOB > activity_desc.txt
  3. cleartool dump activity:activity_name@\PVOB > activity_dump.txt
  4. cleartool describe -l stream:stream_name@\PVOB > stream_desc.txt
  5. cleartool dump stream:stream_name@\PVOB > stream_dump.txt

Are you trying to complete or cancel the delivery? Sometimes a delivery has proceeded too far for it to be canceled. A brief explanation of whether or why you prefer to cancel rather than complete can help Rational Client Support give you the most appropriate advice.

Finally, provide the actual output of the deliver command you are trying. In some cases it can be useful to enable tracing while doing this, by setting two environment variables:

  1. set TRACE_SUBSYS=*
  2. set TRACE_VERBOSITY=3
  3. cleartool deliver -complete > deliver_trace.txt 2>&1

[{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"UCM: Deliver","Platform":[{"code":"PF033","label":"Windows"}],"Version":"7.0;7.0.1;7.1;7.1.1;7.1.2","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}},{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"UCM: Deliver","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21194392