How to configure WebSphereMQ when the size of Business Object is larger than 4 MB

Technote (troubleshooting)


Problem(Abstract)

The Adapter can't send or receive the Business Object if its size is larger than 4M, and will throw an exception like below:
[Thread: MemCheckerCollab.thread1 (#526608462)] [Type: Trace] [Mesg: javax.jms.JMSException: MQJMS2007: failed to send message to MQ queue
at com.ibm.mq.jms.services.ConfigEnvironment.newException(ConfigEnvironment.java:540)
......]

Cause

The reason is because the Maximum Message Length of the queue manager, which is created by installer, is 4,194,304, it is impossible to receive larger BO and send it to collaboration.

Resolving the problem

You must change the default value for the Maximum Message Length property of the queue manager, queue, and channel you want to use. Use WebSphere MQ Explorer to set these values, by following these steps:

1. Open WebSphere MQ Explorer by selecting Start > Programs > IBM WebSphere MQ > WebSphere MQ Explorer.

2. To change the Maximum Message Length property of your queue manager, do the following:
a. In the left pane, right-click the name of the queue manager (for instance, WebSphereICS.queue.manager) and select Properties.
b. On the Extended tab, change the value of the Maximum Message Length property to 104857600.
c. Click OK.

3. To change the Maximum Message Length property of your queue, do the following:
a. In the left pane, right-click the queue name and select Properties.
b. On the Extended tab, change the value of the Maximum Message Length property to 104857600.
c. Click OK.

4. To change the Maximum Message Length property of your channel, do the following:
a. In the left column, right-click the channel name and select Properties.
b. On the Extended tab, change the value of the Maximum Message Length property to 104857600.
c. Click OK.

At the same time, it is better to increase the values for the LogPrimaryFiles and LogSecondaryFiles properties of the queue manager by following these steps:

1. Open WebSphere MQ Services by selecting Start > Programs > IBM WebSphere MQ > WebSphere MQ Services

2. In the left pane, right-click the name of the queue manager (for instance, WebSphereICS.queue.manager) and select Properties.

3. On the Log tab, increase the values of the LogPrimaryFiles and LogSecondaryFiles properties.

LogPrimaryFiles: Default 3, range 2-62. Suggested value: 60

LogSecondaryFiles: Default 2, range 1-61. Suggested value: 20

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Document information


More support for:

WebSphere Business Integration Server Express

Software version:

4.3.1

Operating system(s):

Windows 2000, Windows Server 2003, Windows XP

Software edition:

All Editions

Reference #:

1177724

Modified date:

2011-11-06

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