IBM Support

MustGather: Out of Memory Errors on HP-UX

Troubleshooting


Problem

MustGather for troubleshooting WebSphere Application Server java.lang.OutOfMemoryError errors on HP-UX. Gathering this information before calling IBM support will help familiarize you with the troubleshooting process and save you time.

Cause

Two conditions can cause a java.lang.OutOfMemoryError:

  • The Java™ virtual machine (JVM) might run out of Java heap space to allocate a Java object.

  • The JVM might not be able to allocate the native memory that it needs to create or execute it's threads.

Resolving The Problem

If you have already contacted support, continue on to the component-specific MustGather information. Otherwise, refer to MustGather: Read first for all WebSphere Application Server products.


Out of Memory specific MustGather information


If a memory problem is suspected in the JVM, or if an IBM Support Technician has asked for HP-UX MustGather data, first follow these steps:

  1. Enable verboseGC:

    See: http://www.ibm.com/support/docview.wss?uid=swg21114927

  2. Enable heap dumps:

    -XX:+HeapDump

  3. Stop the WebSphere Application Server and recycle the logs


  4. Restart the application server



After making the above changes, when the next OutOfMemoryError is thrown collect the following and submit the data to IBM support.
  1. Collect the following information:
    • verboseGC output
    • any heap dumps (.hprof) files that were generated
    • All files in the following directory:

      install_root/profiles/profile_name/logs/server_name
    • All files in the following directory:

      install_root/profiles/profile_name/logs/ffdc
    • A copy of server.xml located in the following directory:

      install_root/profiles/profile_name/config/cells/cell_name/nodes/node_name/servers/server_name



    Note: For all versions, If you have configured the application server to write logs into a different location, send them accordingly.

Follow instructions to Submitting Diagnostic Information to IBM Technical Support for Problem Determination.

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Document Information

Modified date:
15 June 2018

UID

swg21164686