IBM Support

MQOPEN receives 2035 for remote queue

Troubleshooting


Problem

When a MQOPEN is issued against a queue on a remote box, it receives reason code 2035, Not authorized.

Cause

Open options OOSETA (allow all context to be set) and OOSAVA (save context) were being used on the MQOPEN. The WebSphere MQ for iSeries System Administration Guide states when using the MQOO_SET_ALL_CONTEXT on the MQOPEN or MQPUT1 apis, *SETALL authority is required for both the queue and the queue manager.

Resolving The Problem

Grant the user issuing the MQOPEN *SETALL authority to both the local and remote queue managers and the remote queue.

For example,

The MQOPEN is being performed against the queue MSGACP.MQSTDR.RTR.INPUT. This queue is on Queue Manager, TEST.
The application doing the MQOPEN is running on Queue Manager, WBSTEST.
The user profile this application is running under is called MQUSER.


Give the MQUSER user profile *SETALL authority to the WBSTEST Queue Manager.
GRTMQMAUT OBJ(WBSTEST) OBJTYPE(*MQM) USER(MQUSER) AUT(*SETALL) MQMNAME(WBSTEST)

Give the MQUSER user profile *SETALL authority to the TEST Queue Manager.
GRTMQMAUT OBJ(TEST) OBJTYPE(*MQM) USER(MQUSER) AUT(*SETALL) MQMNAME(TEST)

Give the MQUSER user profile *SETALL authority to the MSGACP.MQSTDR.RTR.INPUT queue.
GRTMQMAUT OBJ(MSGACP.MQSTDR.RTR.INPUT) OBJTYPE(*Q) USER(MQUSER) AUT(*SETALL) MQMNAME(TEST)

[{"Product":{"code":"SSFKSJ","label":"WebSphere MQ"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Security","Platform":[{"code":"PF012","label":"IBM i"}],"Version":"9.0;8.0;7.1;7.0.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
15 June 2018

UID

swg21163027