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Nodeagent fails to start with JSAS0026E error after enabling global security


Technote (troubleshooting)


Problem(Abstract)

After enabling Global Security in IBM® WebSphere® Application Server V5 releases, the nodeagent does not start. The error messages in the nodeagent SystemOut.log are similar to these:

[3/4/04 12:23:41:573 EST] 2a2c23 SASRas E JSAS0026E:
[SecurityTaggedComponentAssistorImpl.register] Exception connecting
object to the ORB. Check the SSL configuration to ensure that the SSL
keyStore and trustStore properties are set properly. ...

[3/4/04 12:23:46:956 EST] 2a2c23 WsServer E WSVR0003E: Server
nodeagent failed to start
org.omg.CORBA.INTERNAL: CREATE_LISTENER_FAILED_4 minor code:

Cause

The cause is a port conflict. WebSphere global security uses SSL internally, so certain SSL Listener ports are used when WebSphere global security is enabled, regardless of whether SSL is enabled. If one or more of the SSL Listener ports is not available, the nodeagent fails to start.

Resolving the problem

  1. Stop all WebSphere processes: Application Servers, nodeagents, and the deployment manager.

  2. View all ports in use on the operating system by issuing a netstat -a command. Make note of any ports in use.

  3. Check the serverindex.xml file under WebSphere\DeploymentManager\config\cells\cellnamel\nodes\nodename directory for the port numbers assigned to the nodeagent.
    If any of the ports in serverindex.xml are listed as in use (Step 2), this is the source of the problem.

    All the ports should be checked, but the ports relevant to global security are these three:

    SAS_SSL_SERVERAUTH_LISTENER_ADDRESS
    CSIV2_SSL_MUTUALAUTH_LISTENER_ADDRESS
    CSIV2_SSL_SERVERAUTH_LISTENER_ADDRESS

  4. Resolve the port conflict by editing the serverindex.xml and change the conflicting port number to one that is not in use, then restart all the WebSphere processes.

    Below is an example of the default node agent ports as defined in serverindex.xml.

    This same information is in the Administrative Console at:
    System Administration > Nodeagent > End Points.

    serverType="NODE_AGENT">
    <specialEndpoints xmi:id="NamedEndPoint_1077055291759"
    endPointName="BOOTSTRAP_ADDRESS">
    <endPoint xmi:id="EndPoint_1077055291753" host="172.20.229.27"
    port="2809"/>
    </specialEndpoints>
    <specialEndpoints xmi:id="NamedEndPoint_1077055291751"
    endPointName="ORB_LISTENER_ADDRESS">
    <endPoint xmi:id="EndPoint_1077055291754" host="172.20.229.27"
    port="9900"/>
    </specialEndpoints>
    <specialEndpoints xmi:id="NamedEndPoint_1077055291752"
    endPointName=" SAS_SSL_SERVERAUTH_LISTENER_ADDRESS">
    <endPoint xmi:id="EndPoint_1077055291755" host="172.20.229.27"
    port="9901"/>
    </specialEndpoints>
    <specialEndpoints xmi:id="NamedEndPoint_1077055291753"
    endPointName=" CSIV2_SSL_MUTUALAUTH_LISTENER_ADDRESS">
    <endPoint xmi:id="EndPoint_1077055291756" host="172.20.229.27"
    port="9101"/>
    </specialEndpoints>
    <specialEndpoints xmi:id="NamedEndPoint_1077055291754"
    endPointName=" CSIV2_SSL_SERVERAUTH_LISTENER_ADDRESS">
    <endPoint xmi:id="EndPoint_1077055291757" host="172.20.229.27"
    port="9201"/>
    </specialEndpoints>
    <specialEndpoints xmi:id="NamedEndPoint_1077055291755"
    endPointName="NODE_DISCOVERY_ADDRESS">
    <endPoint xmi:id="EndPoint_1077055291758" host="172.20.229.27"
    port="7272"/>
    </specialEndpoints>
    <specialEndpoints xmi:id="NamedEndPoint_1077055291756"
    endPointName="NODE_MULTICAST_DISCOVERY_ADDRESS">
    <endPoint xmi:id="EndPoint_1077055291759" host="232.133.104.73"
    port="5000"/>
    </specialEndpoints>
    <specialEndpoints xmi:id="NamedEndPoint_1077055291760"
    endPointName="DRS_CLIENT_ADDRESS">
    <endPoint xmi:id="EndPoint_1077055291760" host="172.20.229.27"
    port="7888"/>
    </specialEndpoints>
    <specialEndpoints xmi:id="NamedEndPoint_1077055291761"
    endPointName="SOAP_CONNECTOR_ADDRESS">
    <endPoint xmi:id="EndPoint_1077055291761" host="172.20.229.27"
    port="8878"/>
    </specialEndpoints>
    </serverEntries>

Cross Reference information
Segment Product Component Platform Version Edition
Application Servers Runtimes for Java Technology Java SDK

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Document information

WebSphere End of Support Products

WebSphere Application Server


Software version:
5.1, 5.1.0.1, 5.1.1


Operating system(s):
AIX, HP-UX, Linux, Solaris, Windows


Software edition:
Enterprise, Network Deployment


Reference #:
1162691


Modified date:
2004-09-10

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