Web server plug-in policy for WebSphere Application Server

Technote (troubleshooting)


Problem(Abstract)

It is possible to configure your web server plug-in to route requests to WebSphere® Application Server V6.0, V6.1, V7.0, V8.0 and V8.5 releases. This technote provides steps on how to verify what V6.0, V6.1, V7.0, V8.0 and V8.5 plug-in versions are installed on local or remote web servers, and how to determine if the installation complies with supported configurations.

Resolving the problem





Supported web server plug-in and Application Server process combinations

Application Server V8.5 Application Server V8.0 Application Server V7.0 Application Server V6.1 Application
Server V6.0
Web server plug-in V8.5 ** Supported Supported *Supported *Supported *Supported
Web server plug-in V8.0 ** ***Supported Supported *Supported *Supported *Supported
Web server plug-in V7.0 ** ***Supported ***Supported Supported *Supported *Supported
Web server plug-in V6.1 Supported *Supported
Web server plug-in V6.0 Supported

Backward compatibility: V6.1.0.23, 6.0.2.35, 7.0.0.3 plug-in includes APAR PK71492 ($WSFO header). V8.0 & V8.5 base plug-ins also includes $WSFO. If using these plug-in fix pack levels or V8.0 & V8.5 base plug-ins, the Application Server must be at the same fix pack level or higher to support the plug-in $WSFO header functionality. In addition, 7.0.0.13 or higher is recommended over 7.0.0.3 for the reasons indicated in ** below.

** The pluginMerge tool is provided in fix pack V7.0.0.13 for the z/OS and distributed platforms, and in fix pack V7.0.0.17 for the IBM i platform. Version V7.0.0.17, the name of this tool has changed to pluginCfgMerge . The pluginCfgMerge tool is also provided in V8.0.0.0. This tool must be used when merging plugin-cfg.xml files from earlier WebSphere Application Server V6.1 and V6.0 releases when using Web Server plug-in V7 or V8 binaries.

Note: When using the merge tool, the plug-in configuration file must be generated on the same level of WebSphere as the Web server plug-in release. The plug-in configuration can then be merged with older plug-in configuration files, but the first file listed when running the merge tool must be the most current release's configuration file.

Documentation:
V8.5 - pluginCfgMerge
V8.0 - pluginCfgMerge
V7.0 - pluginMerge and pluginCfgMerge
V6.1, V6.0 - manually merging plug-in files from multiple nodes

*** Using IBM HTTP Server 7.0 with web server Plug-in 7.0 as front-end to IBM WebSphere Application Server 8.0 and 8.5 is supported . Support for IBM HTTP Server 8.0 with web server Plug-in 8.0 as a front-end to IBM WebSphere Application Server 8.5 applies here as well.


Notes:
  • The WebSphere Application Server plug-in module is installed on the supported web server that meets minimum software prerequisites.

  • The web server is installed on a server that meets minimum hardware and software prerequisites.

  • The minimum Global Security Kit (GSKIT) level that is required by the WebSphere Application Server plug-in for SSL communication with WebSphere Application Server is installed on a web server.

  • IBM strongly recommends that you use the latest WebSphere Application Server component cumulative plug-in fix pack for the corresponding WebSphere Application Server release. For example, if you are running WebSphere Application Server V7.0x, IBM recommends using the latest 7.0.0.x plug-in fix pack whenever possible.


Support restrictions
  • V6.0 plug-in with V6.0 Application Server: The plug-in must be at the same or higher level than the respective Application Server. For example, a V6.0.0.1 or higher plug-in to a V6.0.0.1 Application Server. (Note:V6.0 is officially out of support as of 30 Sep 2010 - Valid Extended Support Contract must be in place to maintain support of V6.0)

  • V6.1 plug-in with V6.0 Application Server: You are entitled to support for this configuration if you purchased support for V6.1 and V6.0. (Note:V6.0 is officially out of support as of 30 Sep 2010 - Valid Extended Support Contract must be in place to maintain support of V6.0)

  • V6.1 plug-in with V6.1 Application Server: The plug-in must be at the same or higher level than the respective Application Server. For example, a V6.1.0.2 or higher plug-in to a V6.1.0.2 Application Server.

  • V7.0 plug-in with V8.0, V8.5 Application Server: Using the combination of IBM HTTP Server 7.0 and IBM web server Plugin 7.0 in deployments with IBM WebSphere Application Server 8.0 and 8.5 is now recognized as a supported configuration by IBM. This toleration is provided as a transitional measure to allow users with third-party modules in IBM HTTP Server 7.0, which may not yet be certified by their authors for use in IBM HTTP Server 8.0 and later, to use IBM WebSphere Application Server 8.0 and 8.5. This configuration will remain supported while IBM WebSphere Application Server 7.0 is in standard support. You are entitled to support for this configuration if you purchased support for V7.0 and the V8.0 or V8.5 version being used.

  • V7.0 plug-in with V7.0 Application Server: The plug-in must be at the same or higher level than the respective Application Server. For example, a V7.0.0.3 or higher plug-in to a V7.0.0.3 Application Server.

  • V7.0 plug-in with V6.1 Application Server: You are entitled to support for this configuration if you purchased support for V7.0 and V6.1.

  • V7.0 plug-in with V6.0 Application Server: You are entitled to support for this configuration if you purchased support for V7.0 and V6.0. (Note:V6.0 is officially out of support as of 30 Sep 2010 - Valid Extended Support Contract must be in place to maintain support of V6.0)

  • V8.0 plug-in with V8.0 Application Server: The plug-in must be at the same or higher level than the respective Application Server. For example, a V8.0.0.1 or higher plug-in to a V8.0.0.1 Application Server.

  • V8.0 plug-in with V7.0 Application Server: You are entitled to support for this configuration if you purchased support for V8.0 and V7.0.

  • V8.0 plug-in with V6.1 Application Server: You are entitled to support for this configuration if you purchased support for V8.0 and V6.1.

  • V8.0 plug-in with V6.0 Application Server: You are entitled to support for this configuration if you purchased support for V8.0 and V6.0. (Note:V6.0 is officially out of support as of 30 Sep 2010 - Valid Extended Support Contract must be in place to maintain support of V6.0)

  • V8.5 plug-in with V8.5 Application Server: The plug-in must be at the same or higher level than the respective Application Server. For example, a V8.5.0.1 or higher plug-in to a V8.5.0.1 Application Server.

  • V8.5 plug-in with V8.0 Application Server: You are entitled to support for this configuration if you purchased support for V8.5 and V8.0.

  • V8.5 plug-in with V7.0 Application Server: You are entitled to support for this configuration if you purchased support for V8.5 and V7.0.

  • V8.5 plug-in with V6.1 Application Server: You are entitled to support for this configuration if you purchased support for V8.5 and V6.1.

  • V8.5 plug-in with V6.0 Application Server: You are entitled to support for this configuration if you purchased support for V8.5 and V6.0. (Note:V6.0 is officially out of support as of 30 Sep 2010 - Valid Extended Support Contract must be in place to maintain support of V6.0)


Upgrade recommendations


Review minimum hardware and software prerequisites for the web server and WebSphere Application Server; refer to the Detailed system requirements for WebSphere Application Server.
Downloading upgrades

Download the latest WebSphere Application Server component cumulative plug-in fixes from Recommended fixes for WebSphere Application Server.
Supported GSKit levels in WebSphere Application Server plug-ins

The GSKIT required by the WebSphere Application Server plug-in is used for SSL encryption between the plug-in (web server) and WebSphere Application Server. It does not automatically mean that the same GSKIT version is used for SSL encryption for the traffic between the web server and the client (such as a browser). These WebSphere Application Server/GSKIT combinations are required by WebSphere Application Server plug-ins:



WebSphere Application Server V6.0 plug-ins
GSKIT 7 is used for all web server plug-ins with the following exceptions:
  • Solaris
    • IPlanet/Sun One web server plug-in uses GSKIT 4

WebSphere Application Server V6.1 plug-ins
GSKIT 7 is used for all web server plug-ins


WebSphere Application Server V7.0 plug-ins
GSKIT 7 is used for all web server plug-ins


WebSphere Application Server V8.0 & V8.5 plug-ins
GSKIT 8 is used for all web server plug-ins


The GSKIT library required by WebSphere Application Server plug-in must be installed during WebSphere Application Server installation. If the GSKIT library required by WebSphere Application Server plug-in is missing on the Web server, download and install IBM HTTP Server (IBM HTTP Server), which includes the GSKIT library.

Note: GSKIT7 is installed with IBM HTTP Server V6.0, V6.1, and V7.0 releases. GSKIT8 is installed with IBM HTTP Server V8.0 and V8.5

For the IBM HTTP Server, the web server plug-in is supported on the following versions:
  • Plug-in 6.0 supported on IBM HTTP Server 6.0
  • Plug-in 6.1 supported on IBM HTTP Server 6.0.2, 6.1
  • Plug-in 7.0 supported on IBM HTTP Server 6.1, 7.0
  • Plug-in 8.0 supported on IBM HTTP Server 8.0
  • Plug-in 8.5 supported on IBM HTTP Server 8.5

Cross reference information
Segment Product Component Platform Version Edition
Application Servers WebSphere Application Server Plug-in (remote) Install AIX, Linux, Solaris, Windows 7.0, 6.1.1, 6.1, 6.0.1, 6.0, 5.1
Application Servers Runtimes for Java Technology Java SDK

Rate this page:

(0 users)Average rating

Document information


More support for:

WebSphere Application Server
Plug-in

Software version:

6.0, 6.1, 7.0, 8.0, 8.5

Operating system(s):

AIX, HP-UX, Linux, Solaris, Windows

Reference #:

1160581

Modified date:

2014-02-03

Translate my page

Machine Translation

Content navigation