Troubleshooting
Problem
This technote explains why the IBM® Rational® ClearCase® Atria Location Broker Daemon (ALBD) service does not startup after login to a domain from a Microsoft® Windows® XP client.
Cause
The reason the ALBD service may not start automatically after logging into the domain on a Windows® client is due to a process timing issue where one process starts before the ALBD process causing it to halt.
Note: The ALBD can be started manually in this case.
The problem is known to occur (but not only) when Novell® network is configured in the environment and a login script is used during the login process in to the domain.
Example:
The typical login scenario is as follows: (Domain login > ALBD startup)
When Novell (or other network service) is configured and a startup script is fired after login, the script can cause the ALBD startup process to not start properly or at all: (Domain login > Network service startup script > ALBD).
This is a site-specific issue and not a defect with ClearCase.
Resolving The Problem
WORKAROUND:
Configure the Windows clients that have this startup script to have the ALBD service attempt to restart after the first failure.
- Open the Computer Management Console (Right-click My Computer and select Manage)
- Expand Services and Applications and select Services
- Double-click Atria Location Broker and select Recovery tab
- In the section Select the computer's response if this service fails click the drop down menu under First failure and select Restart the Service
Note: The default interval is 1 minute.
- Click Apply and OK.
- Restart or Log out and log back in to the PC to test the setting.
- The Atria Location Broker (ALBD) should start 1 minute after login. Change the Restart service after interval as needed until the ALBD automatically starts on the affected host.
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Document Information
Modified date:
16 June 2018
UID
swg21150785