Skip to main content

Rational installer incompatible with Windows change journal feature


Technote (troubleshooting)


Problem(Abstract)

Attempts to install version 2003.06.00, 7.0 and 7.1 of IBM Rational products on the Microsoft Windows file system when "change journal" is enabled may result in corruption of the file system.

Symptom

During the installation of a version 2003.06.00, 7.0 and 7.1 IBM Rational product, a pop-up box appears with the following message:


[IBM Rational ClearCase - Setup Wizard]

Product Warnings

Please take note of the following warnings regarding installation of this product onto your machine.

There are some product-specific warnings for this installation:

STOP! Before proceeding with this install, please close all applications and disable anti-virus software. Check http://ibm.com/support/docview.wss?rs=203&context=SW000&q1=1135295&uid=swg21135295 for information on how to prevent potential system corruption.


image

Cause

Rational has determined that under certain circumstances file system (volume) corruption can result from installing Rational Version 2003.06.00, 7.0 and 7.1 products onto an NTFS volume attached to a Windows 2000 system if the volume has a Windows "change journal" on it.

If the corrupted volume is used for booting, the affected system will be rendered unbootable.

The change journal is an NTFS capability introduced by Microsoft in Windows 2000. The change journal is used by various software components (created by Microsoft and other parties) to efficiently monitor changes being made to NTFS volumes. Technical details on the change journal can be found at http://technet.microsoft.com/en-us/library/cc938919.aspx.


Environment

Windows 2000 only


Note: Rational has not seen corruption of volumes attached to Windows XP, Windows Vista, Windows Server or Windows 7 systems or later and believe that changes between Windows 2000 and later versions of the operating system make it unlikely that the problem exists on these other Windows operating systems. Contact support immediately if you experience this corruption issue on versions of Windows other than 2000.


Diagnosing the problem

There are no standard Microsoft Windows 2000 user interfaces (command lines or GUIs) that can be used to determine whether a volume has a Change Journal, or to create or delete a Change Journal; however, Microsoft Windows XP has provided a command-line utility, fsutil.exe, to perform many FAT and NTFS file system related tasks.

Use this utility on Windows 2000 to test if Change Journal is enabled.


To test if Change Journal is active:

  1. Copy fsutil.exe from the [Windows installation folder]\System32 directory from a Windows XP (or later version operating system)
  2. Place the copy into the Windows 2000 [Windows installation folder]\System32
  3. Ensure that you are logged in with Administrator privileges
  4. Open Command prompt on Windows 2000 (Start > Run type cmd)
  5. Type the following command replacing the drive letter by the letter of the bootable drive.

    fsutil usn queryjournal C:

    Note: This command would check drive C:
  • If the Change Journal is not active, and the following will be reported:

    Microsoft Windows [Version 6.1.7601]
    Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

    C:\Windows\system32>fsutil usn queryjournal C:
    "Error:  The volume change journal service is not active."

  • If the Change Journal is active, the following will be reported:

    Microsoft Windows [Version 6.1.7601]
    Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

    C:\Windows\system32>fsutil usn queryjournal C:
    Usn Journal ID   : 0x01cbac684c73dc3e
    First Usn        : 0x0000000076500000
    Next Usn         : 0x0000000078583710
    Lowest Valid Usn : 0x0000000000000000
    Max Usn          : 0x7fffffffffff0000
    Maximum Size     : 0x0000000002000000
    Allocation Delta : 0x0000000000400000

Resolving the problem

Microsoft has identified a defect in the way that the change journal is processed when an NTFS volume is mounted (such as, at system boot time) and has a solution, details of which can be found in Microsoft Article ID: 820888.

If you cannot obtain this fix from Microsoft, Rational strongly recommends that you disable any antivirus software that is protecting the volume that is the target of the installation. Review the documentation for the particular anti-virus software you have installed to determine how to disable.

Note: In some cases this might require that you disable antivirus software on a computer other than the one on which you actually launch the installation process (such as, if the target of the installation is a remote volume).

After the installation is complete, you can enable anti-virus back on the system.


Related information

File Replication in Windows 2000 and Server 2003

Rate this page:

(0 users)Average rating

Copyright and trademark information

IBM, the IBM logo and ibm.com are trademarks of International Business Machines Corp., registered in many jurisdictions worldwide. Other product and service names might be trademarks of IBM or other companies. A current list of IBM trademarks is available on the Web at "Copyright and trademark information" at www.ibm.com/legal/copytrade.shtml.

Rate this page:


(0 users)Average rating

Add comments

Document information

Rational Common Components

Rational Common Installer


Software version:
7.0, 7.0.1, 7.0.2, 7.1, 2003.06.16


Operating system(s):
Windows


Reference #:
1135295


Modified date:
2012-03-31

Translate my page

Content navigation