Unrecognized line in license database

Technote (troubleshooting)


Problem(Abstract)

This technote explains why incorrect information within the IBM Rational ClearCase license key string results in the error, Unrecognized line in license database, along with instructions to resolve the problem.

Symptom

When starting the ALBD service, an automatic check of the license key strings is performed. These license strings are stored in the license.db file on UNIX®, Linux® or the ClearCase Control Panel on Windows®.

If there are invalid strings, which are not recognized as valid entries, errors will be reported within the ALBD log indicating the problematic string.

For example, here is a listing from a UNIX® (or Linux™) license.db file with an invalid license key string:

# cat /var/adm/atria/license.db
-nusers 20980
-invalid string
-licensess ClearCase
-license clEarCAse
-license CleerCase
-unknown
-error

The following errors in the ALBD error log correspond to the entries above:

01/17/02 01:10:24 PM albd_server(21072): Ok: Reading license database file /var/adm/atria/license.db at 01/17/02 01:10:24 PM
01/17/02 01:10:24 PM albd_server(21072): Error: Unrecognized line in license database
Error in line 1 of license database, line is:
-nusers 20980
01/17/02 01:10:24 PM albd_server(21072): Error: Unrecognized line in license database
Error in line 2 of license database, line is:
-invalid string
01/17/02 01:10:24 PM albd_server(21072): Error: Unrecognized line in license database
Error in line 3 of license database, line is:
-licensess ClearCase
01/17/02 01:10:24 PM albd_server(21072): Error: Bad license in license database
Error in line 4 of license database, line is:
-license clEarCAse
01/17/02 01:10:24 PM albd_server(21072): Error: Bad license in license database
Error in line 5 of license database, line is:
-license CleerCase
01/17/02 01:10:24 PM albd_server(21072): Error: Unrecognized line in license database
Error in line 6 of license database, line is:
-unknown
01/17/02 01:10:24 PM albd_server(21072): Error: Unrecognized line in license database
Error in line 7 of license database, line is:
-error

Cause

The entries in the license.db file on UNIX, Linux or the ClearCase Control Panel on Windows are incorrect.


Resolving the problem


Correct the entries in the license.db file on UNIX, Linux or the ClearCase Control Panel on Windows.

Fix the invalid strings reported in the log with valid entries, for example (UNIX or Linux):


    # cat /var/adm/atria/license.db
    -nuser 20980
    -license ClearCase ATRIA *.1 NONE 1235678.12345678.02
    -license ClearCase ATRIA *.1 NONE 1235678.98765432.02
    -license ClearCase ATRIA *.1 NONE 1235678.87634512.02

Related information

About restarting the ClearCase license server
Denying users from pulling a ClearCase license
Revoking a ClearCase license

Cross reference information
Segment Product Component Platform Version Edition
Software Development Rational ClearCase Licensing

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Document information


More support for:

Rational ClearCase
Licensing

Software version:

7.0, 7.0.0.1, 7.0.0.2, 7.0.0.3, 7.0.0.4, 7.0.0.5, 7.0.0.6, 7.0.0.7, 7.0.0.8, 7.0.1, 7.0.1.1, 7.0.1.2, 7.0.1.3, 7.0.1.4, 7.0.1.5, 7.0.1.6, 7.0.1.7, 7.1, 7.1.0.1, 7.1.0.2, 7.1.1, 2003.06.00, 2003.06.16

Operating system(s):

AIX, HP-UX, IRIX, Linux, Solaris, Windows

Reference #:

1134771

Modified date:

2009-12-29

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