Error: db_VISTA error -925

Technote (troubleshooting)


Problem(Abstract)

This technote explains why the IBM® Rational® ClearCase® logs identify database error, db_VISTA -925, and provides instructions to troubleshoot the problem.

Symptom

The following errors may be seen in the db_server_log:

Snippet 1

db_server(29020): Ok: *** db_VISTA database error -925 - error in Transaction Journaling File
db_server(29020): Error: Transaction journal file a suspicious length 2147483647
db_server(29020): Error: DBMS error in "../db__event.c" line 641
db_server(29020): Error: db_VISTA error -925 (errno == "Resource temporarily unavailable")


Snippet 2

db_server(5112): Error: db_server.exe(5112): Error: Cannot open database in "c:\ClearCase_Storage\VOBs\test.vbs\db"
db_server(5112): Error: db_server.exe(5112): Error: db_VISTA error -925 (errno == "No such file or directory")
db_server(5112): Warning: : status -925
db_server(5112): Warning: Invalid TJF file hdr


Snippet 3

db_server.exe(8492): Error: Cannot open database in "d:\ClearCase_Storage\VOBs\test1.vbs\db"
db_server 8492 db_server.exe(8492): Error: db_VISTA error -925 (errno == "Bad file descriptor")

Cause

This error can relate to one of the following problems:

  • Corrupt Transaction File

  • Database Limitations

  • Incomplete Transaction File

  • This can also be caused by extra vista.tjf.xxxx files in the VOBs db directory

Resolving the problem

CORRUPT TRANSACTION FILE:

If the transaction files are considered corrupted, the following steps can resolve the corruption.

Note: Renaming the transaction files do not impact checkouts. Checkout information is committed to the database automatically, thus the transaction files do not contain checkout information.

  1. Lock the VOB (if you receive errors from the lock command, proceed to step 2.)

  2. Unmount the VOB

  3. Kill any lingering VOB processes on the server using the albd_list utility.

    Note: Review technote 1148639 for more details on albd_list and its usage.

  4. Should some ClearCase processes still exist that are accessing the transaction files and preventing you from deleting them, you must completely stop ClearCase on the server to end those processes.

  5. Move the vista.tjf, vista.tcf, vista.taf files out of the VOB db directory
    Refer to technote 1149322 About ClearCase database vista.* files for further information about these files.

  6. Remount the VOB

  7. The files will be recreated and the VOB will be functional

    Note: If the files are not recreated, stop and restart ClearCase services on the host.


DATABASE LIMITATIONS:

Check the size of the string file (vob_db.str_file) and transaction files (vista.tjf, vista.taf, vista.tcf) in the VOB storage db directory. These files may have reached their maximum size limitation of 2 gigabytes.

For additional information about database file size limitations for the different schema versions, refer to technote 1124619 About the 2 Gigabyte limitation of VOB database files.

String File: Review technote 1122951 for more information on reducing the size of the string file.


Note: If the transaction files (vista.*) sizes are under 2 gigabytes, it is possible that the transaction files have become corrupted. Follow the same instructions above to resolve the problem.


INCOMPLETE TRANSACTION FILE:

The transaction files could be incomplete if there is not enough disk space on the partition to which the files are stored.

  1. Check your disk space and free up storage as needed.

  2. Follow the steps outlined above in the corrupt transaction file section to resolve the issue.


EXTRA VISTA.TCF FILES

Remove the vista.tcf files from the VOB db directory
Refer to technote 1149322 About ClearCase database vista.* files for further information about removing these files.

Cross reference information
Segment Product Component Platform Version Edition
Software Development Rational ClearCase Database
Software Development Rational ClearCase Database

Rate this page:

(0 users)Average rating

Document information


More support for:

Rational ClearCase
Database

Software version:

7.0, 7.0.1, 7.1, 7.1.1, 2003.06.00, 2003.06.16

Operating system(s):

AIX, HP-UX, IRIX, Linux, Solaris, Windows

Reference #:

1133944

Modified date:

2012-12-26

Translate my page

Machine Translation

Content navigation