IBM Support

Rational product launch results in "FLEXlm Error -88, System clock has been set back" error

Troubleshooting


Problem

Attempts to launch an IBM Rational product results in the error "Failed to check out a key".

Symptom

The full error message is as follows:

Failed to check out a key for RationalSuiteEnterprise:
FLEXlm Error -88, System clock has been set back

Changing the time back does not fix the error.

Cause

The system time of the license server has been set back, either via the Date / Time Property on Windows, or in the BIOS.

Resolving The Problem

Reset the time on the license server to the correct date and time normally fixes the problem.

However, if you went into BIOS to change the time, and set the time back to what it should be, but the error still does not seem to go away, stop and restart your Rational License Server.

Another possible cause is that certain files were created during while the system time was being set forward. So search your drive for any file that was created after today's date, and remove them.

[{"Product":{"code":"SSTMW6","label":"Rational License Key Server"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"FLEXlm","Platform":[{"code":"PF033","label":"Windows"}],"Version":"2003.06.16;7.0;7.0.0.1;7.0.0.2;7.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21132859