IBM Support

Error: Failed to read from registry, when checking in a schema in ClearQuest Designer

Troubleshooting


Problem

This technote explains a cause and solution for a Failed to read from registry error that could occur in IBM® Rational® ClearQuest®, when attempting to check in the schema.

Cause

This error could occur when trying to check-in a schema from an earlier version of Rational ClearQuest, where a new package version has been applied. Schema work had previously been done on a machine with Rational ClearQuest 2002.05.00. When attempting to check in the schema, the user receives the following error:

Failed to read from registry: "Software\Rational Software\ClearQuest Packages\Email\6.0\DataPath", name: "DataPath".

Note: The error above references the Email 6.0 package. However, this error could occur for other packages that were introduced in version 2002.05.00.

Resolving The Problem

To resolve this issue, you will need to save work and check the schema in from a machine with Rational ClearQuest 2002.05.00 or higher. You must upgrade all machines where schema design work will be done, to the same version of Rational ClearQuest.



[{"Product":{"code":"SSSH5A","label":"Rational ClearQuest"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Designer - Checkin and Checkout","Platform":[{"code":"PF033","label":"Windows"}],"Version":"2001a.04.00;2002.05.00;2002.05.20","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Historical Number

150176720

Document Information

Modified date:
16 June 2018

UID

swg21131627