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Unable to update snapshot view due to an update in progress

Troubleshooting


Problem

This technote explains why an IBM® Rational® ClearCase® snapshot view update may fail due to the error, Error: A snapshot view update is in progress, along with instructions to resolve the problem.

Symptom


A snapshot view update results in the following error:

cleartool: Error: A snapshot view update is in progress (since 10/28/02 03:03:21 PM by vobadmin@host1 (process 476)).
cleartool: Error: Unable to set config spec.
cleartool: Error: Unable to change configuration specification: error detected by ClearCase subsystem.

Cause


The .access_info file which stores the view access event information may have been corrupted. This could have been the result of a machine or view server crash.

Resolving The Problem

A new .access_info file needs to be regenerated.

  1. End the view server processes for this view by running the following command:

    cleartool endview -server <viewtag>
  2. Set in the view storage directory (.vws) to locate the .access_info file.
  3. Delete the .access_info file
  4. Set back into the snapshot view and run the update again (cleartool update)

[{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"View: Snapshot","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF015","label":"IRIX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"2003.06.00;7.0;7.0.1;7.1;7.1.1;7.1.2","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}},{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"View: Snapshot","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
29 September 2018

UID

swg21130887