Reconnecting to ClearQuest after vendor database information changes

Technote (FAQ)


Question

What are the steps needed to reset database connection information after changes are made in the vendor database used by IBM Rational ClearQuest?

Cause

After changing the back-end vendor database password, host name, or other details, users will not be able to connect to their Rational ClearQuest databases.

Answer

To resolve this issue you are required to change the vendor database information within Rational ClearQuest. For schema repositories you use the ClearQuest Maintenance Tool, and for user databases you use ClearQuest Designer.

Here is an example situation, where you must change the database password:

  1. Change the user password using the vendor database tools. Your database administrator will be able perform this task. If password has already been set, proceed to step 2.

  2. The database connection properties stored in the schema repository now can be updated by using the update option in the ClearQuest Maintenance Tool.

    Note: Perform this action as a Microsoft Windows user with administrative privileges.

    1. Select the connection to be updated in the ClearQuest Maintenance tool.

    2. Select Schema Repository from the top menu, then select Update > Selected Connection.

    3. Enter the updated password, then click the Next button.

    4. Enter the Rational ClearQuest administrators user name and password. This is the account with superuser privileges in ClearQuest, then click Next.

    5. When update is complete, click Done. If this process fails, verify that both your vendor database user name and password are both correct and have proper permissions as well as the ClearQuest superuser account.

  3. Next, export the updated connection profile to distribute to users of the Rational ClearQuest client.

    Note: With ClearQuest Web, you only need to update the connection profile on the Windows server

    1. Select File from the top menu, then check the box of the connection you wish to export.
      Note:
      It is possible to select additional connections, but this example primarily is concerned with this one particular connection.

    2. Specify the file name to export to, or keep the default file name specified, then click Finish.

    3. When update is complete, click Done.

  4. The exported file can now be distributed to the users of the Rational ClearQuest client for import. All users of this client must update their setting to be able to connect to this ClearQuest database.

    1. To import the profile, select File from the top menu of the ClearQuest Maintenance tool.

    2. Select "Import Profile", then enter the name of the file you wish to import, or use the ellipse button to search for the file and press the Open button.

    3. Click the Next button to continue.

    4. Review and verify the Schema Repository properties for the connection or connections to be updated, then click Finish.

    5. Click Yes to proceed with overwriting the existing connections.

    6. Upon successful completion of the import, click Done, then click Exit. If the import fails, review the settings in step "d" and try again.

  5. If your user database passwords have also changed, they can be updated using the ClearQuest Designer using the following steps.

    Note: Updating user database passwords only needs to be done once for all users.

    1. Open your connection with the ClearQuest Designer. Do not open a schema.

    2. In ClearQuest Designer 7.0.x and earlier versions, select Database from the top menu, then select Update User database Properties... In ClearQuest Designer 7.1.x and later versions, access the ClearQuest Database Admin view.

    3. In ClearQuest Designer 7.0.x and earlier versions, select the database to update. Press Properties to continue. In ClearQuest Designer 7.1.x and later versions, right-click on the database. Select Show Properties.

    4. In ClearQuest Designer 7.0.x and earlier versions, enter the new password and click Update. When action is complete, click OK, then click Cancel on the remaining dialog box. In ClearQuest Designer 7.1.x and later versions, change the password. Close the Properties view. Right-click on the database and select Save.

  6. You should now be able to connect to your Rational ClearQuest databases using the updated connection.

Note: In version 7.0.1, there are some instances where the PORT value for an existing connection cannot be changed by updating. If the PORT value persists, you must create a new connection with the correct port value.


Cross Reference information
Segment Product Component Platform Version Edition
Software Development Rational ClearQuest Designer - Database Administration

Historical Number

17811

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Document information


More support for:

Rational ClearQuest
Maintenance tool

Software version:

7.0, 7.0.1, 7.1, 7.1.1, 7.1.2

Operating system(s):

Windows

Reference #:

1124616

Modified date:

2008-03-24

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