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Error: Unknown host 'xxx': [WINSOCK] Host not found

Troubleshooting


Problem

This technote explains why the error, []Error: Unknown host 'xxx': [WINSOCK] Host not found[], may occur when using IBM® Rational® ClearCase®.

Symptom


  1. Attempts to run a credmap command results in the following error:

    C:\Program Files\Rational\ClearCase\etc\utils>credmap foo
    Identity on local system:
     User: DOM1\jdoe (NT:S-1-5-21-1607275091-1726037764-648285020-1004)
     Primary group: DOM1\clearuser
    NT:S-1-5-21-1607275091-1726037764-648285020-1007)
     Groups: (8)
       DOM1\None (NT:S-1-5-21-1607275091-1726037764-648285020-513)
       Everyone (NT:S-1-1-0)
       DOM1\Debugger Users
    NT:S-1-5-21-1607275091-1726037764-648285020-1009)
       BUILTIN\Administrators (NT:S-1-5-32-544)
       BUILTIN\Users (NT:S-1-5-32-545)
       NT AUTHORITY\INTERACTIVE (NT:S-1-5-4)
       NT AUTHORITY\Authenticated Users (NT:S-1-5-11)
       LOCAL (NT:S-1-2-0)

    Identity on host "foo":
    credmap: Error: Unknown host 'foo': [WINSOCK] Host not found
    credmap: Error: Unable to find albd
    credmap: Error: Unknown host 'foo': [WINSOCK] Host not found
    credmap: Error: Unable to find albd
    credmap_local_to_remote_sid returned ClearCase object not found

  2. After changing the machine name of the ClearCase registry server errors like the following are reported when performing various ClearCase operations:

    unknown host hostname:[WINSOCK] valid name, no data record of requested type

    OR

    C:\cleartool  lsvob
    cleartool: Error: Unknown host 'xxx': [WINSOCK] Host not found

Cause


The above errors may be caused by either of the following:

  1. The credmap utility was given an invalid host name as a parameter in the command. The HOST name is either spelled incorrectly or is no longer a valid name. In the example above "foo" is the incorrect hostname.

  2. The ClearCase registry server machine name was changed but the value of the atriaregy Windows registry key located at:
    HKEY_LOCAL_MACHINE\SOFTWARE\Atria\ClearCase\CurrentVersion
    was still pointing to the old machine name on the Registry Server.
  3. Another cause could be that the host is not in the DNS table.

Diagnosing The Problem

Attempt to ping the hostname used in the credmap command:

  1. Perhaps the host name is not being resolved:

    %>ping foo
    Unknown host foo.

    or
    C:\>ping foo
    Ping request could not find host foo. Please check the name and try again.

  2. If ping does return output, use the IP address or the fully qualified name (foo.ibm.com) of the host in the credmap output instead:

    Example:
    C:\>credmap 9.34.75.11
    Identity on local system:
      User: DOM1\jdoe (NT:S-1-5-21-1607275091-1726037764-648285020-1004)
     Primary group: DOM1\clearuser (NT:S-1-5-21-1607275091-1726037764-648285020-1007)
     Groups: (8)
       DOM1\None (NT:S-1-5-21-1607275091-1726037764-648285020-513)
       Everyone (NT:S-1-1-0)
       DOM1\Debugger Users (NT:S-1-5-21-1607275091-1726037764-648285020-1009)
       BUILTIN\Administrators (NT:S-1-5-32-544)
       BUILTIN\Users (NT:S-1-5-32-545)
       NT AUTHORITY\INTERACTIVE (NT:S-1-5-4)
       NT AUTHORITY\Authenticated Users (NT:S-1-5-11)
       LOCAL (NT:S-1-2-0)


    Identity on host "9.34.75.11":
     User SID: UNIX:UID-22319
     Primary group SID: 110
     Group SID list: (1)
       NOBODY

Resolving The Problem


  • If you are using the correct hostname when running the credmap utility and it is not being resolved, you will need to work with your Network admin to determine the cause or continue to use the IP address when running the credmap command.

  • If it was determined that the hostname setting in the Windows registry is incorrect (as referenced in cause 2 above), it will need to be changed as follows:
    Note: This solution contains information about modifying the system registry. Before making any modifications to the Microsoft® Windows® Registry Editor, it is strongly recommended that you make a backup of the existing registry. For more information describing how to back up the registry, refer to the Microsoft Knowledge Base article 256986.
    1. Open the Windows registry editor, Start > Run > type regedit > click OK

    2. Browse to the following registry key:
      HKEY_LOCAL_MACHNE\SOFTWARE\Atria\ClearCase\CurrentVersion

    3. In the right-hand pane of the Registry editor, check the value of the AtriaRegykey

      Make sure it is set to the correct ClearCase registry server hostname.

      If it contains the wrong value, double-click the AtriaRegy key and change the value to the correct host name of the ClearCase registry server.

  • Ensure that the hostname is in the DNS table

[{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Utilities and Tools","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"7.0.1;7.0;2003.06.16;2003.06.00","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}},{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Credmap Server","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}},{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"ClearCase Registry","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21122774