IBM Support

Error when performing a rebase or deliver: Operation corrupted. Unable to check operation common

Troubleshooting


Problem

While using the IBM® Rational® ClearCase® ClearQuest® UCM integration, an integration activity is deleted from ClearQuest before the completion of a rebase or deliver operation results in the error, Operation corrupted. Unable to check operation common.

Symptom

One of the following errors occurs during a deliver operation:

  • Error retrieving delivery state for stream 'stream:dev1@\my_pvob'.
    View "integration" does not have a current activity.  It should be set to an integration activity "SAMPL00004396". Operation corrupted.
    Unable to check operation common.
  • cleartool: Error: IDispatch error #14094
    UCMUtilityActivity SAMPL00004396 does not exist or has already been deleted.

Cause

These errors are related to one of the following problems:

  1. The ClearQuest activity state for the related delivery is set to Complete. This prevents the activity from being shown as Active in ClearCase, thus causing the deliver failure. Check the status of the ClearQuest activity.

    Example from ClearCase Project Explorer:
    1. Open ClearCase Project Explorer (Start > Run type: clearprojexp)
    2. Expand PVOB > Project and click Integration Stream (the Deliver Activities appear in the right pane)
    3. Select the activity from the error, Right click for Properties and select the UCM tab.
    4. Check the Status field of the activity.
  2. If the ClearQuest activity is not set to Complete, then these errors are due to defect RATLC00683457. This problem affected version 2002.05. The defect allows an activity to be removed from ClearQuest even though it has a change set. This puts the deliver operation in a invalid state because the view is set to an activity that no longer exists.

This problem can also occur it the activity referenced in the error message is not set to the view.

Resolving The Problem

  1. If the ClearQuest activity is set to Complete, change the status to Reopen. Then perform the deliver operation again from the development view. The activity should now be recognized in the view for the deliver to complete.
  2. If the problem is related to the defect, it has been resolved in 2003.06.00 and later.
    Note: For version 2002.05.00, see the below workaround.

    2002.05.00 Workaround:
    With ClearCase version 2002.05.00, the use of the squid_doctor can be used to resolve this problem.

    SQUID_DOCTOR:  <RATIONAL>\ClearCase\etc\utils\ucmutil squid_doctor -fix -ccscan activity:<activity selector>


    Note: The squid_doctor command can be run without -fix first to check the result.
    For example:


    % ucmutil squid_doctor -ccscan activity:CQPR00004396@\my_pvob


    Run the command again with the -fix option to resolve the problem.
    For example:

    % ucmutil squid_doctor -fix -ccscan activity:CQPR00004396@\my_pvob


    The squid_doctor will restore the ClearQuest activity and you should be able to complete the deliver or rebase operation.

    Note: Ensure the correct activity is set (CQPR00004396 in this example) prior to completing the rebase/deliver operation.

To avoid this situation in the future, add a restriction for the DELETE action in the ClearQuest user database.

[{"Product":{"code":"SSSTXH","label":"Rational Integrations"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"UCM ClearCase and ClearQuest","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"2002.05.00;2002.05.20;2003.06.00;2003.06.12;2003.06.13;2003.06.14;2003.06.15;2003.06.16","Edition":"","Line of Business":{"code":"","label":""}},{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"UCM: ClearQuest Integration","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB36","label":"IBM Automation"}},{"Product":{"code":"SSSH5A","label":"Rational ClearQuest"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Integrations: IBM","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Historical Number

120812407

Document Information

Modified date:
04 December 2018

UID

swg21120848