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Using Rational ClearCase results in IDispatch error 14022

Troubleshooting


Problem

Using IBM Rational ClearCase with Rational ClearQuest integrated enabled results in an IDispatch error #14022 during file check in or check out actions.

Symptom

Attempts to check out or check in a file from Rational ClearCase with Rational ClearQuest integration enabled results in the following error:


IDispatch error #14022
  Permission denied for user <username> to perform action Submit (of type SUBMIT)
  Unable to connect the integration activity to ClearQuest
  Unable to create integration activity
  Unable to do integration

Note: This issue can also occur during a Unified Change Management (UCM) deliver or rebase operation.


IDispatch error #14022
   Permission denied for user <username> to perform action deliver (of type CHANGE_STATE)
   Unable to perform ClearQuest deliver policy action for ClearQuest UCM_Project "<ucm_project_name>"; Unable to complete transition of activity "<activity ID>".
   Unable to complete deliver operation - ClearQuest notification failed for at least one activity.
   Unable to post ClearQuest policy notification.
   Unable to complete integration.

Cause

This error is caused by having an Access Control set for a particular action.

Resolving The Problem

Modify the Access Control for that particular action in Rational ClearQuest Designer.

  1. Open Rational ClearQuest Designer

  2. Select the schema to edit

  3. Open the schema

  4. Click the plus sign + next to the Record Types folder to expand the folder

  5. Click the plus sign + next to the BaseCMActivity (or which ever record type you are using)

  6. Click the plus sign + next to the States and Actions folder

  7. Double click Actions and a grid will appear in the right hand panel

    Note: The Access Control of Submit action on the BaseCMActivity Record Type needs to be set to ALL USERS
  8. Look at the Access Control column for the Action Name you have in your schema

    Note: When you receive IDispatch error #14022, you may notice that at least one Action Name has 'User Groups' or 'Use Hook' in the Access Control column.

    You can change the restriction on an Action Name by clicking in the field at the junction of the Access Control column and the Action Name row. After you click that field you may choose one from three Access Control options.

    The three Access Control options are Scripts (Use Hook for older versions), All Users and User Groups. The setting that prompted the error is too restrictive for the user experiencing the error such as Scripts (Use Hook) or User Groups. If it is set to either User Groups or Scripts (Use Hook), make sure all Rational ClearCase users are defined. The Rational ClearCase user being used is the login/password defined the first time the integration is run.

[{"Product":{"code":"SSSTXH","label":"Rational Integrations"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Base ClearCase and ClearQuest","Platform":[{"code":"PF033","label":"Windows"}],"Version":"7.0;7.0.1","Edition":"","Line of Business":{"code":"","label":""}},{"Product":{"code":"SSSTXH","label":"Rational Integrations"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"UCM ClearCase and ClearQuest","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"","label":""}}]

Document Information

Modified date:
16 June 2018

UID

swg21119940